[1.0-RC1] Trying to login with graphcool(1.0) and got error


#1

versions

  • graphcool/1.0.0-beta4.1.1

I tried with typescript-advanced boilerplate and it works fine with local cluster.
I wanted to deploy to cloud so I tried to login with graphcool command line.
And It got me this error message with export DEBUG="*"

Error: Unexpected end of JSON input: {"response":{"data":null,"errors":[{"message":"Unexpected end of JSON input","locations":[],"path":[]}],"status":200},"request":{"query":"mutation {\n      requestCloudToken {\n        secret\n      }\n    }"}}
    at GraphQLClient.<anonymous> (/Users/oiojin_pink/.config/yarn/global/node_modules/graphql-request/src/index.ts:46:13)
    at step (/Users/oiojin_pink/.config/yarn/global/node_modules/graphql-request/dist/src/index.js:40:23)
    at Object.next (/Users/oiojin_pink/.config/yarn/global/node_modules/graphql-request/dist/src/index.js:21:53)
    at fulfilled (/Users/oiojin_pink/.config/yarn/global/node_modules/graphql-request/dist/src/index.js:12:58)
    at <anonymous>
    at process._tickDomainCallback (internal/process/next_tick.js:228:7)
Exiting with code: 1

Thanks


#2

I am keep getting this error as well

Error: Project not found: 'soren~cloud-api@prod':

I can’t login… I tried to remove graphcool and even grapcool-framwork and tried it again and reinstall but not working.


#3

Thanks, I can confirm this problem in the RC1. We’re looking to roll out a fix later today, there is nothing required from your end to fix this. I’ll update this message once this is fixed :slightly_smiling_face: