Couldn't connect to Docker daemon error message


#1

I am trying to go through the example here. https://github.com/graphcool-examples/react-graphql/tree/master/quickstart-with-apollo

When I deploy it locally and issue the command graphcool local up
I receive this error.
Couldn't connect to Docker daemon - you might need to run docker-machine start default.

Any help would be appreciated. I am on a mac with the latest macOS High Sierra installed. docker and docker-compose are both installed also.

I also ran docker-machine start default and received this error.

failed MSpanList_Insert 0xb3b000 0x3f6467fc13206 0x0
fatal error: MSpanList_Insert

runtime stack:
runtime.throw(0xa52ddb)
	/usr/src/go/src/pkg/runtime/panic.c:520 +0x69
runtime.MSpanList_Insert(0xa6e928, 0xb3b000)
	/usr/src/go/src/pkg/runtime/mheap.c:618 +0x8a
MHeap_FreeLocked(0xa6a920, 0xb3b000)
	/usr/src/go/src/pkg/runtime/mheap.c:447 +0x1a6
MHeap_Grow(0xa6a920, 0x10)
	/usr/src/go/src/pkg/runtime/mheap.c:341 +0x1ae
MHeap_AllocLocked(0xa6a920, 0x1, 0x2)
	/usr/src/go/src/pkg/runtime/mheap.c:222 +0x379
runtime.MHeap_Alloc(0xa6a920, 0x1, 0x10000000002)
	/usr/src/go/src/pkg/runtime/mheap.c:178 +0x7b
MCentral_Grow(0xa72d38)
	/usr/src/go/src/pkg/runtime/mcentral.c:265 +0x89
runtime.MCentral_CacheSpan(0xa72d38)
	/usr/src/go/src/pkg/runtime/mcentral.c:84 +0x14b
runtime.MCache_Refill(0xb37000, 0x2)
	/usr/src/go/src/pkg/runtime/mcache.c:78 +0x119
runtime.mallocgc(0x10, 0x0, 0x10)
	/usr/src/go/src/pkg/runtime/malloc.goc:152 +0x30e
runtime.malloc(0x10)
	/usr/src/go/src/pkg/runtime/malloc.goc:264 +0x39
runtime.mallocinit()
	/usr/src/go/src/pkg/runtime/malloc.goc:575 +0x2a5
runtime.schedinit()
	/usr/src/go/src/pkg/runtime/proc.c:150 +0x36
_rt0_go()
	/usr/src/go/src/pkg/runtime/asm_amd64.s:91 +0x114

Thanks for any help!


#2

Can you provide more information?

  • graphcool version
  • docker version, docker toolbox version (looks like you are using that, and not docker for Mac)
  • output of docker ps

Thanks :slightly_smiling_face:


#3

graphcool version: graphcool/0.9.2 (darwin-x64) node-v8.6.0
docker version 1.0.0

output of docker ps

    Saved file tree to doc-filelist.js
    Copied JS to doc-script.js
    Compiled CSS to doc-style.css

#4

Your docker version looks suspicious, it should be something similar to 17.09.0, but that aside: Did you install docker for mac or did you install docker toolbox?


#5

Thanks for your help but I ended up using something else for my app.