New version 1.31 admin doesn't load data


#1

I had install version 1.31 with Postgres in local, but the administrator does not load data, does not show any errors in the registry of the console or in the docker log.

I’m forgetting something?

❯ docker logs 0dca61716f3b
No log level set, defaulting to INFO.
[INFO] {} - Started.
[INFO] Initializing workers…
[INFO] Obtaining exclusive agent lock…
[INFO] Successfully started 1 workers.
[INFO] Obtaining exclusive agent lock… Successful.
[INFO] Deployment worker initialization complete.
Server running on :4467
[Warning] Management authentication is disabled. Enable it in your Prisma config to secure your server.
[Debug] Initializing deployment worker for default$default
[Debug] Scheduling deployment for project default$default
[Debug] Applied migration for project default$default


#2

Can you please clear your localStorage and try again? If the problem persist, please let us know.


#3

I deleted locaStorage but still doesn’t work, then I deleted all browser cache and now it works!
Thanks


#4

i also got this error and cleared localStorage and cach but still loading.
on firefox i got this error in the console:

Source link error : request failed with status 404
resource URL : https://cdn.jsdelivr.net/npm/@prisma/prisma-admin@0.2/dist/app.js
resource URL link : main.6db3a4fd.js.map[learn more]

#5

i changed my docker to version 1.30 clear all data (local storage and cookie) and it works well,
waiting to find a solution for the 1.31 docker version

on the 1.31 i did try a prisma introspect and the result is

 ▸    Could not connect to database. Project not found: 'prisma-temporary-service$temporary-stage':
 ▸    {"response":{"errors":[{"message":"Project not found:
 ▸    'prisma-temporary-service$temporary-stage'","code":3016,"requestId":"local:cjuqyvxll000z0728hkyfq3k8"}],"status":200},"request":{"query":"{\n
 ▸    __type(name: \"PrismaDatabase\") {\n        kind\n        enumValues {\n          name\n        }\n      }\n    }"}}

Get in touch if you need help: https://spectrum.chat/prisma
To get more detailed output, run $ export DEBUG="*"

my prisma.yml got this endpoint

# Specifies the HTTP endpoint of your Prisma API.
endpoint: ${env:PRISMA_ENDPOINT}/${env:PRISMA_EP_SERVICE}/${env:PRISMA_EP_STAGE}

missing something? any clues?


#6

me too!

version: '3'
services:
  prisma:
    image: prismagraphql/prisma:1.31
    restart: always
    ports:
      - '4466:4466'
    environment:
      PRISMA_CONFIG: |
        port: 4466
        # uncomment the next line and provide the env var PRISMA_MANAGEMENT_API_SECRET=my-secret to activate cluster security
        # managementApiSecret: my-secret
        databases:
          default:
            connector: mysql
            host: mysql
            user: root
            password: prisma
            rawAccess: true
            port: 3306
            migrations: true
  mysql:
    image: mysql:5.7
    restart: always
    environment:
      MYSQL_ROOT_PASSWORD: prisma
    volumes:
      - mysql:/var/lib/mysql
volumes:
  mysql:


#7

I fixed this problem by copying the docker-compose.yml directly from the getting started page in docs, then rebuilding the entire image and deleting the old db and the underlying docker volume. There may be a less extreme solution.


#8

Cleanning localstorage and cache doesn’t work for me…

My database is deploying on AWS.


#9

Having the same issue with Prisma 1.32.0
Cleared all browser cache. Tried anonymous browser.
Stays in ‘Loading’
All network requests seem to have been finished though. No requests pending.
Datamodel was retrieved.


#10

Me too, I’m using prisma with local postgres


#11

This issue still exist in prisma:1.33 so switched back to prisma:1.29 as it has loading issue while accessing http://localhost:4466/_admin. May be in future need to try switching back to latest or beta.

prisma:
    image: prismagraphql/prisma:1.29

#12

Updating to image: prismagraphql/prisma:1.35-alpha fixed the issue for me or reverting to image: prismagraphql/prisma:1.30 does the trick. Docker images [1.31 - 1.34-alpha] all cause the endless Loading… issue for me.

prisma:
    image: prismagraphql/prisma:1.35-alpha

#13

Yes I confirm prisma v1.35-alpha fixes the issue. however accessing it from prisma.io does not work even with updated version.

{“key”:“error/handled”,“requestId”:“local:cjvy0soo4000t0758fgkruy7v”,“payload”:{“exception”:“com.prisma.deploy.schema.AuthFailure: Invalid signature”,“query”:“query ServiceDetails($_v0_name: String!, $_v1_stage: String!) {\n generateProjectToken(name: $_v0_name, stage: $_v1_stage)\n}\n”,“variables”:"{"_v0_name":“bookis”,"_v1_stage":“prod”}",“code”:“3015”,“stack_trace”:“com.prisma.deploy.schema.SchemaBuilderImpl.verifyAuthOrThrow(SchemaBuilder.scala:314)\n com.prisma.deploy.schema.SchemaBuilderImpl.$anonfun$generateProjectTokenField$1(SchemaBuilder.scala:165)\n sangria.execution.Resolver.resolveField(Resolver.scala:1024)\n sangria.execution.Resolver.$anonfun$collectActionsPar$1(Resolver.scala:445)\n scala.collection.TraversableOnce.$anonfun$foldLeft$1(TraversableOnce.scala:156)\n scala.collection.TraversableOnce.$anonfun$foldLeft$1$adapted(TraversableOnce.scala:156)\n scala.collection.Iterator.foreach(Iterator.scala:937)\n scala.collection.Iterator.foreach$(Iterator.scala:937)\n scala.collection.AbstractIterator.foreach(Iterator.scala:1425)\n scala.collection.IterableLike.foreach(IterableLike.scala:70)\n scala.collection.IterableLike.foreach$(IterableLike.scala:69)\n scala.collection.AbstractIterable.foreach(Iterable.scala:54)\n scala.collection.TraversableOnce.foldLeft(TraversableOnce.scala:156)\n scala.collection.TraversableOnce.foldLeft$(TraversableOnce.scala:154)\n scala.collection.AbstractTraversable.foldLeft(Traversable.scala:104)\n sangria.execution.Resolver.collectActionsPar(Resolver.scala:439)\n sangria.execution.Resolver.resolveFieldsPar(Resolver.scala:45)\n sangria.execution.Executor.executeOperation(Executor.scala:155)\n sangria.execution.Executor.$anonfun$execute$7(Executor.scala:97)\n scala.concurrent.Future.$anonfun$flatMap$1(Future.scala:303)\n scala.concurrent.impl.Promise.$anonfun$transformWith$1(Promise.scala:37)\n scala.concurrent.impl.CallbackRunnable.run(Promise.scala:60)\n akka.dispatch.BatchingExecutor$AbstractBatch.processBatch(BatchingExecutor.scala:55)\n akka.dispatch.BatchingExecutor$BlockableBatch.$anonfun$run$1(BatchingExecutor.scala:91)\n scala.runtime.java8.JFunction0$mcV$sp.apply(JFunction0$mcV$sp.java:12)\n scala.concurrent.BlockContext$.withBlockContext(BlockContext.scala:81)\n akka.dispatch.BatchingExecutor$BlockableBatch.run(BatchingExecutor.scala:91)\n akka.dispatch.TaskInvocation.run(AbstractDispatcher.scala:40)\n akka.dispatch.ForkJoinExecutorConfigurator$AkkaForkJoinTask.exec(ForkJoinExecutorConfigurator.scala:44)\n akka.dispatch.forkjoin.ForkJoinTask.doExec(ForkJoinTask.java:260)\n akka.dispatch.forkjoin.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1339)\n akka.dispatch.forkjoin.ForkJoinPool.runWorker(ForkJoinPool.java:1979)\n akka.dispatch.forkjoin.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:107)”,“message”:“Invalid signature”}}


#14

There is a known issue in Prisma admin. When rawAccess is enabled on a Prisma server, admin fails to load that. This will be fixed in the next release. In the mean time, please re-deploy Prisma server on docker with rawAccess: false to mitigate this issue. Thanks.