No cluster could be found


Dear friends,

When I run prisme deploy I got the following error:

Error: No cluster could be found for workspace '*' and cluster 'default': {"response":{"data":{"generateClusterToken":null},"errors":[{"message":"No cluster could be found for workspace '*' and cluster 'default'","locations":[{"line":3,"column":9}],"path":["generateClusterToken"],"code":222}],"status":200},"request":{"query":"
      mutation ($input: GenerateClusterTokenRequest!) {
        generateClusterToken(input: $input) {
    at GraphQLClient.<anonymous> (/usr/local/lib/node_modules/prisma/node_modules/graphql-request/src/index.ts:72:13)
    at step (/usr/local/lib/node_modules/prisma/node_modules/graphql-request/dist/src/index.js:40:23)
    at (/usr/local/lib/node_modules/prisma/node_modules/graphql-request/dist/src/index.js:21:53)
    at fulfilled (/usr/local/lib/node_modules/prisma/node_modules/graphql-request/dist/src/index.js:12:58)
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:160:7)
Exiting with code: 1

Would you please help me to fix this?

Thank you in advance.


Hi @david.medium9

Can you please tell me your cli version and prisma cloud workspace name(it is listed under settings)



pantharshit, I am using : prisma/1.29.2 (linux-x64) node-v10.15.3

I reverted back from version 1.30 because of this same error. Reverting back seems to have got it working locally but I am getting this error on my DigitalOcean droplet.

Please help me solve this. I would be grateful.



We just released another fix.

Install it via npm i -g prisma@beta. It is in beta currently. You will only need to upgrade your CLI


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.