Prisma deploy doesn't deploy the changed model


How can I apply the datamodel changes? I’m a bit newbie. So, I thought prisma deploy is the way to make the changes. But I tried several times, it doesn’t work. It says it’s successful. But it doesn’t apply the model changes to the demo database in prisma service. So, if I make a changes to the datamodel I always have to make a new service to apply those changes. How can I fix this ?

Any help would be appreciated.


Hi @pankaja92

You can apply changes in your datamodel using prisma deploy. If there are no changes to apply it will not make a deployment.

You will need to run prisma generate to regenerate the client that will be according to the changed datamodel.


I tried prisma deploy . It shows the changes are applying. I can query and use mutations on those newly added types. But the types are not showing in the Databrowser. As I got to know, it’s a bug with Prisma atm, as it doesn’t show newly added changes until we clear cache or something


Oh, that updation issue is a bug in prisma admin. It is not related to prisma server.

You can track progress of that issue here:


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.