SEO and googlebot


#1

I’ve mentioned this in the slack already but thought I would bring it here for more structured discussion. After reading more about prerendering and googlebot I think it makes the most sense to allow bots to access the graph endpoints.

From this thread it seems like adding an empty robots.txt file would remedy the issue.


#2

I have the same issue. I added an empty robot.txt but unfortunately I still get the error “Temporarily unreachable” when the google crawler tries to access my graph.cool endpoint. Any suggestions how to fix this? Any help is appreciated


#3

Same problem here! “Fetch as Google” renders error cards for any of my Graphcool requests


#4

Me and another user (@wallslide) on slack also get a “temporarily unreachable” for requests to the Simple Api when trying to render pages in Google console.

@wallslide also noted:

When I proxied the request through netlify’s rewrite rules (https://www.netlify.com/docs/redirects/#proxying) it worked, which makes me think that requests from googlebot are being blocked for some reason by graphcool

I personally solved this by moving to SSR, but thats not always an easy option e.g. if you’re using Create React App.

It would be helpful to know if Graphcool are deliberately blocking/noindexing the googlebot and if there is anything that could be done to allow requests to the Simple API to be “reachable” so Google can render and index non SSR’d sites properly.


#5

Have you ever test inspection tools ?
https://support.google.com/webmasters/answer/9012289?hl=en

MIPCCTV