Terminal Login Failure - 400 error


When attempting to authenticate via terminal / browser, I get a 400 error and cannot proceed.

The request and response are pasted below.

Any insight is most welcome.


URL: https://api.cloud.prisma.sh/
Status: 400
Source: Network
Address: 2600:9000:2045:5a00:5:6ddb:e00:93a1:443

:method: POST
:scheme: https
:authority: api.cloud.prisma.sh
:path: /
Accept: /
Content-Type: application/json
Origin: https://app.prisma.io
Content-Length: 208
Accept-Language: en-us
Host: api.cloud.prisma.sh
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_1) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0.1 Safari/605.1.15
Referer: https://app.prisma.io/cli-auth?secret=$2a$08$b5WbZm9Ddl0slsDu/wlYJu
Accept-Encoding: br, gzip, deflate
Connection: keep-alive

:status: 400
Access-Control-Allow-Origin: *
Content-Type: text/html; charset=utf-8
Via: 1.1 2b101a605873d7394741d31f6ebf1a67.cloudfront.net (CloudFront), 1.1 cc7c11d5640aeda2bbf41f7aa6cbaa59.cloudfront.net (CloudFront)
Content-Encoding: gzip
Date: Thu, 06 Dec 2018 22:33:29 GMT
Content-Length: 652
Access-Control-Allow-Credentials: true
Vary: Accept
x-amz-cf-id: aCfR62Wd1BzRhufJSmwipGnKaTOTu95rfQ12kbpiqL2Vp8k2mdrOeQ==
x-amzn-trace-id: Root=1-5c09a3b9-e592d1aa9340223610a3cf32;Sampled=0
x-powered-by: Express
x-ratelimit-reset: 1544135610
x-amzn-remapped-date: Thu, 06 Dec 2018 22:33:29 GMT
x-amz-apigw-id: RgaE9FSDjoEFpoA=
x-ratelimit-remaining: 499
x-ratelimit-limit: 500
x-amzn-requestid: f44cef76-f9a6-11e8-8791-9f484fd8a96e
x-cache: Error from cloudfront

Request Data
MIME Type: application/json
Request Data:



Ran into the same error yesterday and pulled my hair over it for a few hours. If your company uses a proxy, make sure you’ve set environment variables http_proxy and https_proxy, and if by any chance you are using bash on Windows, try switching over to Powershell for that command. That worked for me :).

Good day !


I have the same error and I am on a mac at home using wifi connection? any ideas? This error also happened at work and I thought at the time the firewall could be the issue. Is there another way to get authentified as a fallback?

many thanks


I also had this same issue, but I couldn’t get any of the above solutions to work.

However, I did manage to fix it by creating an account first at https://app.prisma.io

Then I was able to run prisma deploy and authenticate successfully.


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.