Unsupported config option for services.prisma: 'managementApiSecret'


#1

Hi
I got this the message error when i execute the command docker-compose up -d

ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:
Unsupported config option for services.prisma: 'managementApiSecret’

Everything work well without the managementApiSecret key.

This error occur with the new version 1.32 of prisma. I did not get this error before.

Below is my docker-compose.yml file.

version: ‘3’
services:
prisma:
image: prismagraphql/prisma:1.32
restart: always
managementApiSecret: 2a09f06732e9-e0c0-4ade-b5a8-4134dd19cc7e6a
ports:
- “4466:4466”
environment:
PRISMA_CONFIG: |
port: 4466
databases:
default:
connector: mongo
uri: mongodb://username:password@host:27017/dbadminname
database: dbname

Please any help.
Thank


#2

Hi,

managmentApiSecret is not a top level docker-compose property. You will need to define it inside of PRISMA_CONFIG like so:

version: '3'
services:
  prisma:
    image: prismagraphql/prisma:1.32
    restart: always
    ports:
      - '4466:4466'
    environment:
      PRISMA_CONFIG: |
        port: 4466
        managementApiSecret: 2a09f06732e9-e0c0-4ade-b5a8-4134dd19cc7e6a
        databases:
          default:
            connector: mongo
            uri: mongodb://username:password@host:27017/dbadminname
            database: dbname

#3

Hi
Thank you very much.