Skip to main content

System requirements

This page provides an overview of the system requirements for Prisma ORM.

System requirements

This section lists the software that Prisma ORM requires and the supported operating systems, along with runtime dependency requirements for specific operating systems.

Software requirements

The latest version of Prisma ORM requires the following software:

Minimum required version
Node.js16.13 / 18.X / 20.X
TypeScript (optional)4.7.X
Yarn (optional)1.19.2

Notes:

See also: Supported database versions

Operating systems

Prisma ORM is supported on MacOS, Windows and most Linux distributions.

Linux runtime dependencies

Prisma ORM requires the following system libraries to be installed to work:

  • OpenSSL 1.0.x, 1.1.x or 3.x
  • zlib (libz.so.1)
  • libgcc (libgcc_s.so.1)
  • C standard library (glibc on most Linux distributions or musl libc on Alpine Linux)

The following two tables show the supported Linux distro families, OpenSSL versions and C standard libraries for each CPU architecture.

On AMD64 (x86_64) architecture:

Distro familyOpenSSL versionlibc version
Alpine1.1.x, 3.xmusl 1.2.x
RHEL1.0.x, 1.1.x, 3.xglibc 2.17+
Debian or others1.0.xglibc 2.19+
Debian or others1.1.x, 3.xglibc 2.24+

On ARM64 (aarch64) architecture:

Distro familyOpenSSL versionlibc version
Alpine1.1.x, 3.xmusl 1.2.x
RHEL1.0.x, 1.1.x, 3.xglibc 2.24+
Debian or others1.0.x, 1.1.x, 3.xglibc 2.24+

When Prisma ORM can not resolve the OpenSSL version on a system (e.g. because it is not installed), it will default to OpenSSL 1.1.x.

Systems that can run the supported Node.js versions will most likely have zlib and libgcc available. One notable exception is Google's Distroless images, where libz.so.1 needs to be copied from a compatible Debian system.

Windows runtime dependencies

On Windows Microsoft Visual C++ Redistributable 2015 or newer must be installed (which is by default the case on most modern installations).

macOS runtime dependencies

Prisma ORM supports macOS 10.15 or newer. There are no additional platform-specific requirements on macOS other than what is listed for all platforms in the Software requirements section.

Troubleshooting

There are some common problems caused by using outdated versions of the system requirements:

Unable to build a TypeScript project with @prisma/client

Problem

You see the following error when you try type-checking a project after you run prisma generate.

./node_modules/.prisma/client/index.d.ts:10:33
Type error: Type expected.
8 | export type PrismaPromise<A> = Promise<A> & {[prisma]: true}
9 | type UnwrapTuple<Tuple extends readonly unknown[]> = {
> 10 | [K in keyof Tuple]: K extends `${number}` ? Tuple[K] extends PrismaPromise<infer X> ? X : never : never
| ^
11 | };
12 |
13 |

Solution

Upgrade the TypeScript dependency in your project to a version supported by Prisma ORM. npm install -D typescript.

Unable to use groupBy preview feature

Problem

You see the following console error when you attempt to run an app that uses the groupBy feature:

server.ts:6:25 - error TS2615: Type of property 'OR' circularly references itself in mapped type '{ [K in keyof { AND?: Enumerable<ProductScalarWhereWithAggregatesInput>; OR?: Enumerable<ProductScalarWhereWithAggregatesInput>; ... 4 more ...; category?: string | StringWithAggregatesFilter; }]: Or<...> extends 1 ? { ...; }[K] extends infer TK ? GetHavingFields<...> : never : {} extends FieldPaths<...> ? never : K...'.
6 const grouped = await prisma.product.groupBy({
~~~~~~~~~~~~~~~~~~~~~~~~
7 by: ['category']
~~~~~~~~~~~~~~~~~~~~
8 });
~~~~
server.ts:6:48 - error TS2554: Expected 0 arguments, but got 1.
6 const grouped = await prisma.product.groupBy({
~
7 by: ['category']
~~~~~~~~~~~~~~~~~~~~
8 });
~~~

Solution

Upgrade the TypeScript dependency in your project to a version supported by Prisma ORM. npm install -D typescript.