<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8"/><meta http-equiv="x-ua-compatible" content="ie=edge"/><style data-href="/dataguide/styles.c636567fa40f17d6c6ab.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 2.30.3"/><title data-react-helmet="true">Comparing conventional and serverless databases</title><link data-react-helmet="true" rel="canonical" href="https://www.prisma.io/dataguide/serverless/traditional-vs-serverless-databases"/><link data-react-helmet="true" rel="icon" href="data:image/png;base64,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"/><meta data-react-helmet="true" name="viewport" content="width=device-width, initial-scale=1"/><meta data-react-helmet="true" name="description" content="Learn about the advantages and disadvantages of self-managed databases, managed databases, and serverless databases."/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:site" content="@prisma"/><meta data-react-helmet="true" name="twitter:title" content="Comparing conventional and serverless databases"/><meta data-react-helmet="true" name="twitter:description" content="Learn about the advantages and disadvantages of self-managed databases, managed databases, and serverless databases."/><meta data-react-helmet="true" name="twitter:creator" content="@prisma"/><meta data-react-helmet="true" name="twitter:image" content="https://www.prisma.io/dataguide/social/docs-social.png"/><meta data-react-helmet="true" property="og:url" content="https://www.prisma.io/dataguide/serverless/traditional-vs-serverless-databases"/><meta data-react-helmet="true" property="og:title" content="Comparing conventional and serverless databases"/><meta data-react-helmet="true" property="og:description" content="Learn about the advantages and disadvantages of self-managed databases, managed databases, and serverless databases."/><meta data-react-helmet="true" property="og:site_name" content="Prisma&#x27;s Data Guide"/><meta data-react-helmet="true" property="og:type" content="website"/><meta data-react-helmet="true" property="og:image" content="https://www.prisma.io/dataguide/social/docs-social.png"/><meta data-react-helmet="true" property="og:image:alt" content="Prisma&#x27;s Data Guide"/><meta data-react-helmet="true" property="og:image:type" content="image/png"/><meta data-react-helmet="true" property="og:image:width" content="1200"/><meta data-react-helmet="true" property="og:image:height" content="630"/><style data-styled="hSmnUr jGDNMO kHZfpW fmxOwh cVekrW bcfNLx cyqhKw jwmlip kHPKUM kpaIAg bWNIOR gUpGFq lmFDlL hsjqRs keHlXB kkkHOW kBqHOD eHtASS kgNgFY dloams hpWsEz clttwx eeOKop kqMtkp jOTGAl eXpVtv jcIJnf fhjAMq bzaeW" data-styled-version="4.4.1">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</style><style data-styled="bMtlmz" data-styled-version="4.4.1">
/* sc-component-id: sc-gzVnrw */
.bMtlmz{max-width:880px;width:880px;margin:0.5rem 0 1rem 0;position:relative;z-index:100;} @media (min-width:0px) and (max-width:1024px){.bMtlmz{width:100%;max-width:100%;}}</style><link rel="sitemap" type="application/xml" href="/dataguide/sitemap.xml"/><script>window.dataLayer = window.dataLayer || [];window.dataLayer.push({"website":"dataguide"}); (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-KCGZPWB');</script><link as="script" rel="preload" href="/dataguide/webpack-runtime-1cbb84544ff5c92b5a82.js"/><link as="script" rel="preload" href="/dataguide/framework-260c11da1cc53725f6de.js"/><link as="script" rel="preload" href="/dataguide/app-c7044d5daf7d47198f21.js"/><link as="script" rel="preload" href="/dataguide/styles-e9d24b1846c7d6eb9685.js"/><link as="script" rel="preload" href="/dataguide/commons-6a03fed22e77ce84b1e9.js"/><link as="script" rel="preload" href="/dataguide/component---src-layouts-article-layout-tsx-9059e882c0a657cdd977.js"/><link as="fetch" rel="preload" href="/dataguide/page-data/serverless/traditional-vs-serverless-databases/page-data.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/dataguide/page-data/sq/d/3649180363.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/dataguide/page-data/sq/d/3662830458.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/dataguide/page-data/sq/d/3740740500.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/dataguide/page-data/app-data.json" crossorigin="anonymous"/></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KCGZPWB" height="0" width="0" style="display: none; visibility: hidden" aria-hidden="true"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div class="banner__BannerWrapper-mvhat3-0 hSmnUr"><div class="banner__BannerText-mvhat3-1 jGDNMO"><a href="/dataplatform">Manage your application data in one place with the <strong>Prisma Data Platform</strong>. Learn more -&gt;</a></div></div><div class="header__HeaderWrapper-sc-1ohc4aq-0 kHZfpW"><div class="container"><div class="header__HeaderNav-sc-1ohc4aq-1 fmxOwh"><div style="display:flex"><a style="color:white;text-decoration:none;display:flex;align-items:center" href="/dataguide/"><div class="header__LogoContainer-sc-1ohc4aq-3 cVekrW"><svg width="64" height="64" viewBox="0 0 64 64" fill="none" xmlns="http://www.w3.org/2000/svg" class="Logo-fvvsj4-0 bcfNLx"><rect width="64" height="64" rx="12" fill="url(#paint0_linear)"></rect><path fill-rule="evenodd" clip-rule="evenodd" d="M49.0186 46.0734L27.3284 52.4484C26.6657 52.6434 26.0306 52.0737 26.1699 51.4096L33.9186 14.5324C34.0635 13.8428 35.0227 13.7333 35.3254 14.3719L49.6725 44.648C49.9431 45.2191 49.6344 45.8926 49.0186 46.0734ZM52.7382 44.5696L36.1262 9.51376C35.7096 8.63739 34.8401 8.05838 33.8548 8.00476C32.8439 7.94626 31.9382 8.43076 31.4273 9.25539L13.4107 38.2542C12.8526 39.158 12.8635 40.2725 13.4424 41.1653L22.2492 54.7224C22.7741 55.5316 23.6835 56 24.6288 56C24.8967 56 25.1661 55.9625 25.4311 55.8845L50.9948 48.371C51.7779 48.1407 52.4182 47.5902 52.7533 46.8605C53.0873 46.1304 53.082 45.2949 52.7382 44.5696Z" fill="#EBF4FF"></path><defs><linearGradient id="paint0_linear" x1="32" y1="0" x2="32" y2="64" gradientUnits="userSpaceOnUse"><stop stop-color="#667EEA"></stop><stop offset="1" stop-color="#4C51BF"></stop></linearGradient></defs></svg><span>Prisma&#x27;s Data Guide</span></div></a></div></div><div class="sc-htpNat cyqhKw"><div class="header__DocsMobileButton-sc-1ohc4aq-4 jwmlip">Menu</div></div><div class="header__PrismaLink-sc-1ohc4aq-6 kHPKUM">Modern Database Access for TypeScript &amp; Node.js<a href="https://www.prisma.io" target="_blank" class="header__PrismaButton-sc-1ohc4aq-7 kpaIAg">Explore Prisma</a></div></div></div><div class="layout__Wrapper-brko2w-0 bWNIOR"><section class="layout__NotMobile-brko2w-2 gUpGFq"><div><aside class="sidebar__SidebarContainer-sy974m-0 lmFDlL"><div><div></div><div id="sidebar-container" class="sc-bwzfXH hsjqRs"><ul class="sidebar__List-sy974m-1 keHlXB"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/intro"><span>Introduction to databases</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/intro/what-are-databases" href="/dataguide/intro/what-are-databases"><span>What are databases?</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/intro/comparing-database-types" href="/dataguide/intro/comparing-database-types"><span>Comparing database types: how database types evolved to meet different needs</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/intro/intro-to-schemas" href="/dataguide/intro/intro-to-schemas"><span>Introduction to database schemas</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/intro/database-glossary" href="/dataguide/intro/database-glossary"><span>Glossary of common database terminology</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/datamodeling"><span>Data Modeling</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/intro-dont-panic" href="/dataguide/datamodeling/intro-dont-panic"><span>Intro (Don&#x27;t Panic)</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/know-your-problem-space" href="/dataguide/datamodeling/know-your-problem-space"><span>Know Your Problem Space</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/tables-tuples-types" href="/dataguide/datamodeling/tables-tuples-types"><span>Tables, Tuples, Types</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/correctness-constraints" href="/dataguide/datamodeling/correctness-constraints"><span>Correctness and Constraints</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/making-connections" href="/dataguide/datamodeling/making-connections"><span>Making Connections</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/functional-units" href="/dataguide/datamodeling/functional-units"><span>Functional Units</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/in-vivo" href="/dataguide/datamodeling/in-vivo"><span>In Vivo: Information Ecosystems</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/types"><span>Database types</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/types/relational" href="/dataguide/types/relational"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Relational Databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/postgresql"><span>PostgreSQL</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/benefits-of-postgresql" href="/dataguide/postgresql/benefits-of-postgresql"><span>The benefits of PostgreSQL</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/getting-to-know-postgresql" href="/dataguide/postgresql/getting-to-know-postgresql"><span>Getting to know PostgreSQL</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/5-ways-to-host-postgresql" href="/dataguide/postgresql/5-ways-to-host-postgresql"><span>5 ways to host PostgreSQL databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/setting-up-a-local-postgresql-database" href="/dataguide/postgresql/setting-up-a-local-postgresql-database"><span>Setting up a local PostgreSQL database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/connecting-to-postgresql-databases" href="/dataguide/postgresql/connecting-to-postgresql-databases"><span>Connecting to PostgreSQL databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/authentication-and-authorization" href="/dataguide/postgresql/authentication-and-authorization"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Authentication and authorization</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/create-and-delete-databases-and-tables" href="/dataguide/postgresql/create-and-delete-databases-and-tables"><span>How to create and delete databases and tables in PostgreSQL</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/introduction-to-data-types" href="/dataguide/postgresql/introduction-to-data-types"><span>An introduction to PostgreSQL data types</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/column-and-table-constraints" href="/dataguide/postgresql/column-and-table-constraints"><span>An introduction to PostgreSQL column and table constraints</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/date-types" href="/dataguide/postgresql/date-types"><span>Working with dates in PostgreSQL</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/inserting-and-modifying-data" href="/dataguide/postgresql/inserting-and-modifying-data"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Inserting and modifying data</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/reading-and-querying-data" href="/dataguide/postgresql/reading-and-querying-data"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Reading and querying data</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/short-guides" href="/dataguide/postgresql/short-guides"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Short guides</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/mysql"><span>MySQL</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/5-ways-to-host-mysql" href="/dataguide/mysql/5-ways-to-host-mysql"><span>5 ways to host MySQL databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/setting-up-a-local-mysql-database" href="/dataguide/mysql/setting-up-a-local-mysql-database"><span>Setting up a local MySQL database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/connecting-to-mysql-databases" href="/dataguide/mysql/connecting-to-mysql-databases"><span>Connecting to MySQL databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/authentication-and-authorization" href="/dataguide/mysql/authentication-and-authorization"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Authentication and authorization</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/create-and-delete-databases-and-tables" href="/dataguide/mysql/create-and-delete-databases-and-tables"><span>How to create and delete databases and tables in MySQL</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/introduction-to-data-types" href="/dataguide/mysql/introduction-to-data-types"><span>An introduction to MySQL data types</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/column-and-table-constraints" href="/dataguide/mysql/column-and-table-constraints"><span>An introduction to MySQL column and table constraints</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/inserting-and-modifying-data" href="/dataguide/mysql/inserting-and-modifying-data"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Inserting and modifying data</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/reading-and-querying-data" href="/dataguide/mysql/reading-and-querying-data"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Reading and querying data</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/sqlite"><span>SQLite</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/setting-up-a-local-sqlite-database" href="/dataguide/sqlite/setting-up-a-local-sqlite-database"><span>Setting up a local SQLite database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/importing-and-exporting-data-in-sqlite" href="/dataguide/sqlite/importing-and-exporting-data-in-sqlite"><span>Importing and exporting data in SQLite</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/creating-and-deleting-databases-and-tables" href="/dataguide/sqlite/creating-and-deleting-databases-and-tables"><span>Creating and deleting databases and tables with SQLite</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/inserting-and-deleting-data" href="/dataguide/sqlite/inserting-and-deleting-data"><span>Inserting and deleting data with SQLite</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/basic-select" href="/dataguide/sqlite/basic-select"><span>How to perform basic queries with `SELECT` with SQLite</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/update-data" href="/dataguide/sqlite/update-data"><span>How to update existing data with SQLite</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/mssql"><span>Microsoft SQL Server</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mssql/setting-up-a-local-sql-server-database" href="/dataguide/mssql/setting-up-a-local-sql-server-database"><span>Setting up a local SQL Server database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/mongodb"><span>MongoDB</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/setting-up-a-local-mongodb-database" href="/dataguide/mongodb/setting-up-a-local-mongodb-database"><span>Setting up a local MongoDB database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/connecting-to-mongodb" href="/dataguide/mongodb/connecting-to-mongodb"><span>Connecting to MongoDB databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/configuring-mongodb-user-accounts-and-authentication" href="/dataguide/mongodb/configuring-mongodb-user-accounts-and-authentication"><span>How to manage users and authentication in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/authorization-and-privileges" href="/dataguide/mongodb/authorization-and-privileges"><span>How to manage authorization and privileges in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/creating-dbs-and-collections" href="/dataguide/mongodb/creating-dbs-and-collections"><span>How to manage databases and collections in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/managing-documents" href="/dataguide/mongodb/managing-documents"><span>How to manage documents in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/querying-documents" href="/dataguide/mongodb/querying-documents"><span>How to query and filter documents in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/mongodb-datatypes" href="/dataguide/mongodb/mongodb-datatypes"><span>Introduction to MongoDB data types</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/database-tools"><span>Database tools | SQL, MySQL, Postgres | Prisma&#x27;s Data Guide</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/database-tools/top-nodejs-orms-query-builders-and-database-libraries" href="/dataguide/database-tools/top-nodejs-orms-query-builders-and-database-libraries"><span>Top 11 Node.js ORMs, Query Builders &amp; Database Libraries in 2021</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/database-tools/evaluating-type-safety-in-the-top-8-typescript-orms" href="/dataguide/database-tools/evaluating-type-safety-in-the-top-8-typescript-orms"><span>Top 8 TypeScript ORMs, Query Builders, &amp; Database Libraries: Evaluating Type Safety</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/managing-databases"><span>Managing databases | Prisma&#x27;s Data Guide</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/database-troubleshooting" href="/dataguide/managing-databases/database-troubleshooting"><span>Troubleshooting Database Outages and Connection Issues</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/how-to-spot-bottlenecks-in-performance" href="/dataguide/managing-databases/how-to-spot-bottlenecks-in-performance"><span>How to Spot Bottlenecks in Performance</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/syncing-development-databases-between-team-members" href="/dataguide/managing-databases/syncing-development-databases-between-team-members"><span>Syncing Development Databases Between Team Members</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/database-replication" href="/dataguide/managing-databases/database-replication"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Database Replication</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/serverless"><span>Serverless architecture | Prisma&#x27;s Data Guide</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/serverless/what-is-serverless" href="/dataguide/serverless/what-is-serverless"><span>What is serverless?</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/serverless/serverless-comparison" href="/dataguide/serverless/serverless-comparison"><span>Top 13 serverless computing and database providers</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/serverless/serverless-challenges" href="/dataguide/serverless/serverless-challenges"><span>Introduction to common serverless challenges</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a aria-current="page" class="active-item active-item" id="/dataguide/serverless/traditional-vs-serverless-databases" href="/dataguide/serverless/traditional-vs-serverless-databases"><span>Traditional databases vs serverless databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/serverless/serverless-glossary" href="/dataguide/serverless/serverless-glossary"><span>Serverless Glossary</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/just-for-fun"><span>Just for fun</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/just-for-fun/us-most-popular-databases-by-states" href="/dataguide/just-for-fun/us-most-popular-databases-by-states"><span>The United States&#x27; Most Popular Databases by state going into 2022</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li></ul></li></ul></div></div></aside></div></section><article class="sc-gzVnrw bMtlmz"><div class="layout__MaxWidth-brko2w-1 eHtASS"><section class="top-section"><div class="topSection__TopSectionWrapper-sc-1dezfo1-0 kgNgFY"><h2 class="parentTitleComp__BreadcrumbTitle-sc-1f4ly1o-0 dloams"><span><a href="/dataguide/serverless">Serverless architecture | Prisma&#x27;s Data Guide<!-- --> </a></span></h2><h1 class="topSection__MainTitle-sc-1dezfo1-1 hpWsEz">Traditional databases vs serverless databases</h1><div><h2 class="toc__ChapterTitle-vklla6-0 clttwx">CONTENT</h2><ul class="list"><li><a href="#introduction">Introduction</a></li><li><a href="#traditional-databases-vs-managed-databases-vs-serverless-databases">Traditional databases vs managed databases vs serverless databases</a></li><li><a href="#when-to-use-traditional-databases-and-serverless-databases">When to use traditional databases and serverless databases</a></li><li><a href="#conclusion">Conclusion</a></li></ul></div></div><div class="socialShareSection__SocialWrapper-cg5jms-0 eeOKop"><span>Share on</span><div class="buttons"><a href="https://twitter.com/intent/tweet?text=I%27ve%20found%20this%20page%20on%20%40prisma%27s%20%23DataGuide%20useful%21%20https://www.prisma.io/dataguide/serverless/traditional-vs-serverless-databases" target="_blank"><svg width="20" height="20" viewBox="0 0 20 20" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M4 0C1.79086 0 0 1.79086 0 4V16C0 18.2091 1.79086 20 4 20H16C18.2091 20 20 18.2091 20 16V4C20 1.79086 18.2091 0 16 0H4ZM14.5864 11.7956C15.2274 10.5549 15.529 9.15425 15.4582 7.74675C16.0131 7.46224 16.4447 6.9697 16.6667 6.36758C16.2036 6.60035 15.7052 6.74703 15.1939 6.80103C15.7565 6.48055 16.1767 5.94313 16.3646 5.30365C15.8714 5.63744 15.3193 5.86518 14.7407 5.97353C14.3701 5.49839 13.8526 5.17253 13.277 5.05179C12.7014 4.93105 12.1034 5.02294 11.5856 5.31172C11.0678 5.6005 10.6624 6.06819 10.4388 6.63466C10.2152 7.20113 10.1873 7.8311 10.36 8.41664C9.33168 8.35852 8.32646 8.07599 7.40927 7.5873C6.49209 7.0986 5.68333 6.4146 5.03525 5.57948C4.72018 6.15692 4.61547 6.83362 4.74035 7.48517C4.86524 8.13673 5.21133 8.71935 5.715 9.12592C5.35333 9.13645 4.99343 9.06939 4.6576 8.9289C4.68147 9.55258 4.90735 10.1494 5.29834 10.6218C5.68932 11.0941 6.2223 11.4142 6.81017 11.5296C6.43052 11.647 6.03044 11.674 5.63948 11.6084C5.79989 12.1013 6.09069 12.5368 6.47829 12.8645C6.86588 13.1923 7.33444 13.3989 7.82981 13.4605C6.79012 14.3121 5.48561 14.7331 4.16667 14.6426C5.30811 15.3962 6.62621 15.8078 7.97677 15.8322C9.32732 15.8566 10.6583 15.4929 11.8241 14.781C12.9898 14.069 13.9455 13.0362 14.5864 11.7956Z" fill="#A0AEC0"></path></svg></a></div></div></section><section><h2 id="introduction" style="position:relative"><a href="#introduction" aria-label="introduction permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Introduction</h2><p class="paragraph">The role of databases within many organizations has evolved over time.  While reliance on data to build applications, make business decisions, and provide value in larger ecosystems has increased, the management of the database software and infrastructure itself has, in many cases, shifted.</p><p class="paragraph">While these assets have traditionally been operated by the organization itself, their management has increasingly been outsourced to external providers.  The first iteration of this idea was to move to <em>managed databases</em>, where a provider manages the infrastructure and software while allowing the user to adjust settings and set scaling policies.</p><p class="paragraph">More recently, this idea has evolved to <em>serverless databases</em>, where the entire infrastructure, data storage, and underlying architecture is entirely managed by the provider and the user only accesses the data they manage through API-like interactions.</p><p class="paragraph">In this guide, we&#x27;ll talk about the differences between traditionally deployed databases and their serverless counterparts.  We will discuss managed database offerings where appropriate to help distinguish between the different options providers offer.  Learning about these different concepts can help you understand the trade-offs between different offerings and make an informed decision about what type of database management would make sense for your own projects.</p></section><section><h2 id="traditional-databases-vs-managed-databases-vs-serverless-databases" style="position:relative"><a href="#traditional-databases-vs-managed-databases-vs-serverless-databases" aria-label="traditional databases vs managed databases vs serverless databases permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Traditional databases vs managed databases vs serverless databases</h2><p class="paragraph">Before we dive into the advantages and disadvantages of various strategies, let&#x27;s take a moment to review how the general idea behind how each system works.</p><section><h3 id="traditional-databases" style="position:relative"><a href="#traditional-databases" aria-label="traditional databases permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Traditional databases</h3><p class="paragraph"><em>Traditional databases</em> are the style of databases and database management that has been available for decades.  It involves provisioning a physical or virtual server with the appropriate hardware resources and setting it up as a database server.  Beyond the initial installation and configuration, this type of setup requires:</p><ul class="list"><li>ongoing management of the underlying infrastructure including hardware health, resource management, and network access</li><li>maintaining an up-to-date, stable, and secure operating system, and</li><li>configuring, optimizing, and managing the database management system</li></ul><p class="paragraph">In general, this option provides enormous amounts of control and flexibility.  Every part of the system can be examined, optimized, and changed to suit the needs of the users and applications.</p><p class="paragraph">This comes at the cost of a greater management burden.  All levels of the system must be maintained and optimized to provide ideal application performance while maintaining the availability and security of the system and data.</p></section><section><h3 id="managed-databases" style="position:relative"><a href="#managed-databases" aria-label="managed databases permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Managed databases</h3><p class="paragraph"><em>Managed databases</em> are a product offered by most cloud providers as an alternative to managing your own infrastructure.  Instead, the provider manages the server configuration and database software and exposes options to the user to allow them to configure and tweak the behavior.</p><p class="paragraph">With managed databases, the provider takes responsibility for:</p><ul class="list"><li>ongoing management of the underlying infrastructure including hardware health, resource management, and network access</li><li>maintaining an up-to-date, stable, and secure operating system, and</li><li>managing <em>parts</em> of the database system like the health and functionality of database management system</li></ul><p class="paragraph">The user is still responsible for:</p><ul class="list"><li>making decisions about the optimal settings for their database</li><li>setting policies for scaling, backups, and other software-level configuration</li></ul><p class="paragraph">Generally, this configuration allows the provider to manage the parts of the process that organizations don&#x27;t particularly care about so long as they are maintained to a high standard.  The key configurable areas are still exposed to the user so that they can tune behavior depending on the importance of the resource, operational requirements, and their SLAs.</p><p class="paragraph">Many organizations adopt this style of management because it allows their developers to customize the parts of the database they care about without having to maintain in-house system administration expertise.  It can work well if your needs match well with what the provider had in mind for the product, but can be difficult when you find yourself struggling with the amount of control you are given or if the level of automation is still not what you had hoped for.</p></section><section><h3 id="serverless-databases" style="position:relative"><a href="#serverless-databases" aria-label="serverless databases permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Serverless databases</h3><p class="paragraph"><em>Serverless databases</em> are a relatively new approach offered by cloud providers that takes on an even larger part of the management responsibility from users.  Serverless databases decouple the part of a database management system that deals with storage from the part that executes queries.  This means both can be scaled independently.  In serverless databases, these components are both managed exclusively by the provider.</p><p class="paragraph">In practice, this allows serverless databases to be treated as an infinitely large repository where data can be stored, operated on, and retrieved.  The backend storage will be scaled out as needed and the number of query executors will also be adjusted according to demand.  The user only needs to access the database through an API-like interface that routes commands to the correct components automatically.</p><p class="paragraph">Serverless databases require the least amount of operational management of any of the options we&#x27;ve discussed.  This allows you to use your database as if it were an external service rather than as a component of your infrastructure that you must keep operational.</p></section></section><section><h2 id="when-to-use-traditional-databases-and-serverless-databases" style="position:relative"><a href="#when-to-use-traditional-databases-and-serverless-databases" aria-label="when to use traditional databases and serverless databases permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>When to use traditional databases and serverless databases</h2><p class="paragraph">Now that we&#x27;ve reviewed the approaches taken by different database management strategies, we can talk about what scenarios they&#x27;re best suited for.  While these decisions will primarily come down to your own application requirements, internal expertise, and appetite for optimization and management, there are some general indicators to look for that may help point you in the right direction.</p><section><h3 id="why-would-i-want-to-use-a-traditional-database" style="position:relative"><a href="#why-would-i-want-to-use-a-traditional-database" aria-label="why would i want to use a traditional database permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Why would I want to use a traditional database?</h3><p class="paragraph">The traditional approach of managing the entire stack of your database server from hardware to database software is best suited if you need control, privacy, and performance.</p><section><h4 id="high-level-of-control" style="position:relative"><a href="#high-level-of-control" aria-label="high level of control permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>High level of control</h4><p class="paragraph">While a conventional database server requires continual monitoring, maintenance, and contingency planning to maintain availability, it offers unparalleled levels of control.</p><p class="paragraph">You can choose the infrastructure architecture that suits your specific needs, from a single server to a complex cluster.  You can deploy these assets where ever you want, whether on premises, in data centers with your own or rented hardware, or by using standard compute assets from cloud providers.  You can upgrade and swap out any components as you see fit and tweak any software-level configuration with no boundaries.</p><p class="paragraph">If it is important to you to have the power to change anything at any level of your deployment, then traditional database deployments are probably your best choice.  You will have to pay for this level of control by taking responsibility for managing every part of your deployment.</p></section><section><h4 id="data-privacy-focused" style="position:relative"><a href="#data-privacy-focused" aria-label="data privacy focused permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Data privacy focused</h4><p class="paragraph">If your application data requires very high levels of privacy, either as a feature or as a requirement to conform to any standard or regulation, traditional databases give you the most amount of control.  You will be able to dictate exactly who has access to the physical hardware where they are deployed as well as any software-level access.</p><p class="paragraph">Running your own database servers can ensure that you can put the necessary levels of protection in place for your users and data.  The data for different clients can be placed in different databases, on different servers, or in different physical locations to maintain strict separation.  You can decide on deploying to data centers that meet certain industry standards to ensure that physical access is restricted.</p><p class="paragraph">On the software level, you also start from a place with no external access.  No other parties have management oversight to your services by default.  You can protect your data by refraining from providing access and by setting up encryption and other safeguards to provide the level of protection you require.</p></section><section><h4 id="high-performance" style="position:relative"><a href="#high-performance" aria-label="high performance permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>High performance</h4><p class="paragraph">If your application requires consistent high performance, a conventional database deployment might be your best strategy.</p><p class="paragraph">When running database servers yourself, you can spot and mitigate contention for resources more easily since you have complete insight into the processes and clients competing.  You don&#x27;t have to worry about neighboring customers taking too much of a shared resource and you can provision additional assets as necessary.  The peak performance of your system is limited only by the time and money you allocate and your expertise in managing your systems.</p><p class="paragraph">Especially relevant when comparing to serverless databases is the continual availability of your server database resources.  You do not have cold start problems as you are not scaling down layers of your infrastructure whenever you fall below peak demand.  This can be important if you require consistent performance regardless of the previous level of activity.</p></section></section><section><h3 id="why-would-i-want-to-use-a-serverless-database" style="position:relative"><a href="#why-would-i-want-to-use-a-serverless-database" aria-label="why would i want to use a serverless database permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Why would I want to use a serverless database?</h3><p class="paragraph">Serverless databases also have a significant number of advantages if they fit your use case well.  They are a great choice if you want affordable database access that self-scales without a heavy management burden.</p><section><h4 id="low-cost-operation" style="position:relative"><a href="#low-cost-operation" aria-label="low cost operation permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Low cost operation</h4><p class="paragraph">One of the primary advantages that serverless databases can provide is a low cost of operation.  Because both the storage and the computational layer of the serverless database scale independently, you only pay for exactly what you&#x27;re using.</p><p class="paragraph">The storage layer scales according to how much data you are managing.  This is usually priced according to volume, making the pricing relatively predictable if your application has consistent patterns.  Because this storage backend is dynamically allocated, you never have to worry about running out of space or the costs associated with overprovisioning storage.  The price reflects your storage only.</p><p class="paragraph">The computational layer is completely decoupled and scales using its own criteria.  The number of query executor instances provisioned is determined by the current traffic that your application is passing to the databases.  This means that in times of peak traffic, the service will spin up additional query processors to handle the requests.  On the other hand, when no queries are being executed, the service can scale this layer down to zero, removing the cost of processing entirely during that time.</p><p class="paragraph">If you are very cost sensitive, serverless databases may be a good option because you don&#x27;t need to worry predicting your usage exactly.  The platform&#x27;s resources and your costs scale exactly in line with your usage.</p></section><section><h4 id="high-scalability" style="position:relative"><a href="#high-scalability" aria-label="high scalability permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>High scalability</h4><p class="paragraph">We mentioned this as a function of costs in the last section, but one of the most significant advantages to a serverless database strategy is the ability to scale out easily.  This not only affects expenses, but also your ability to meet varying levels of demand as your usage fluctuates over predictable cycles or changes due to spikes in interest.</p><p class="paragraph">The separate scaling mechanisms for data storage and query execution allow you to handle very different usage scenarios using the same service and configuration.  The service can automatically adjust to accommodate most levels of usage and can grow with your application without any change to the database service.</p><p class="paragraph">High scalability also means that you can experiment with applications easily and move from testing to production without changes to your database service.  You can set up testing and staging databases that will scale down to zero when not in use.  This can be especially useful when practicing continuous integration and continuous delivery because your pipelines can use a database service that perfectly mirrors your production environment while only paying for the small amount of usage your tests require.</p></section><section><h4 id="reduced-management-responsibility" style="position:relative"><a href="#reduced-management-responsibility" aria-label="reduced management responsibility permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Reduced management responsibility</h4><p class="paragraph">Perhaps the biggest highlight for serverless databases is the way they can help offload management responsibilities from your team.  While many organizations have gotten use to the level of administrative overhead required by managed databases, serverless databases take on additional levels of support and management to further reduce your workload.</p><p class="paragraph">Serverless database services not only manage the infrastructure and database management system software, they also manage resource allocation and many of the policies for your databases.  Instead of having to figure out exactly how much storage your database requires or how many database instances are required to serve your average traffic levels, the system can just respond to the conditions it finds.  Instead of managing scaling rules, you can instead just set boundaries for the levels of scaling you desire and the platform will intelligently scale within those constraints.</p><p class="paragraph">This sounds similar to how managed databases are often described, but in practice it ends up being significantly different.  You don&#x27;t have to make many decisions ahead of time with serverless databases.  Mainly, you configure any thresholds for costs that you want to maintain and any specific tweaks to the scaling you want to make, like always having at least one query executor available, for instance.  The system handles nearly everything else to ensure that your application&#x27;s database usage is always available, performing up to standards, and responding to the current request environment.</p></section></section></section><section><h2 id="conclusion" style="position:relative"><a href="#conclusion" aria-label="conclusion permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Conclusion</h2><p class="paragraph">In this article, we took a look at some of the key differences between traditional, self-managed databases and serverless database services.  We talked about how they are different from a user&#x27;s perspective and what trade-offs you must consider when deciding on a database strategy depending on your organization&#x27;s priorities.</p><p class="paragraph">While serverless databases are not suitable for every type of application, they can make database management and operation significantly easier for many organizations.  Understanding when they might be a good solution and what shortcomings they might have can help you figure out if they can and should be considered when evaluating database solutions.</p><div class="sc-ifAKCX kqMtkp">RELATED ON PRISMA.IO<p class="paragraph"><a href="https://www.prisma.io/docs/concepts/components/prisma-data-platform#prisma-data-proxy">Prisma&#x27;s Data Proxy</a>, now in early access, is one way to handle connection issues between your serverless applications and backend databases.  It can help manage ephemeral connections from your serverless functions to avoid exhausting your database connection pool.  Check it out now!</p><div class="prismaOutlinks__LogoWrapper-sc-4gmc34-0 jOTGAl"><span class="icon"><svg width="20" height="24" viewBox="0 0 20 24" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M18.0093 19.0367L7.16418 22.2242C6.83286 22.3217 6.51532 22.0369 6.58494 21.7048L10.4593 3.2662C10.5317 2.92139 11.0114 2.86664 11.1627 3.18595L18.3363 18.324C18.4716 18.6096 18.3172 18.9463 18.0093 19.0367ZM19.8691 18.2848L11.5631 0.756881C11.3548 0.318693 10.9201 0.0291921 10.4274 0.00237954C9.92194 -0.0268705 9.46911 0.21538 9.21364 0.627694L0.205335 15.1271C-0.0737223 15.579 -0.0682506 16.1362 0.221184 16.5827L4.62458 23.3612C4.88704 23.7658 5.34175 24 5.81439 24C5.94836 24 6.08307 23.9813 6.21553 23.9423L18.9974 20.1855C19.3889 20.0704 19.7091 19.7951 19.8767 19.4302C20.0436 19.0652 20.041 18.6474 19.8691 18.2848Z" fill="#63B3ED"></path></svg></span>Prisma is an open-source database toolkit for Typescript and Node.js that aims to make app developers more productive and confident when working with databases.</div></div></section><div class="nextPrevious__NextPreviousWrapper-sc-5jz07g-0 eXpVtv"><div class="previous"><div class="text"><span class="direction">Previous</span><a href="/dataguide/serverless/serverless-challenges"><span class="icon"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="#3182CE" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><line x1="19" y1="12" x2="5" y2="12"></line><polyline points="12 19 5 12 12 5"></polyline></svg></span><div class="title">Introduction to common serverless challenges</div></a></div></div><div class="next"><div class="text"><span class="direction">Next</span><a href="/dataguide/serverless/serverless-glossary"><div class="title">Serverless Glossary</div><span class="icon"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="#3182CE" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><line x1="5" y1="12" x2="19" y2="12"></line><polyline points="12 5 19 12 12 19"></polyline></svg></span></a></div></div></div><div class="pageBottom__PageBottomWrapper-bhhqu2-0 jcIJnf"><div></div><a href="https://github.com/prisma/dataguide/tree/master/content/11-serverless/04-traditional-vs-serverless-databases.mdx" class="edit-git">Edit this page on GitHub</a></div></div></article></div><div class="footer__FooterWrapper-sc-9drt3p-0 fhjAMq"><div class="push-right"><div class="container"><div class="content"><div class="newsletter__NewsLetterWrapper-sc-1b14zu9-0 bzaeW"><h2>Get notified of new articles</h2><p>Sign up to get notified by email when new content is added to Prisma&#x27;s Data Guide.</p><form class="email"><label for="email" aria-label="Insert your email"><input type="text" id="email" placeholder="your@email.com" value=""/></label><button disabled="" type="submit">Subscribe <svg width="20" height="20" viewBox="0 0 20 20" fill="none" xmlns="http://www.w3.org/2000/svg"><circle cx="10" cy="10" r="10" fill="#4C51BF"></circle><path d="M8 6L12.2218 10.2218L8 14.4435" stroke="#F9F9F9" stroke-width="2"></path></svg></button></form></div></div><svg xmlns="http://www.w3.org/2000/svg" width="177" height="153" fill="none" viewBox="0 0 177 153"><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M61.874 96.606c18.924 0 34.265-8.89 34.265-19.856v-8.185H27.608v8.185c0 10.966 15.341 19.856 34.266 19.856z"></path><ellipse cx="61.873" cy="67.943" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M61.874 73.063c18.924 0 34.265-8.89 34.265-19.857v-8.184H27.608v8.184c0 10.967 15.341 19.856 34.266 19.856z"></path><ellipse cx="61.873" cy="44.4" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M61.873 49.519c18.924 0 34.265-8.89 34.265-19.856v-8.185h-68.53v8.185c0 10.966 15.34 19.856 34.265 19.856z"></path><ellipse cx="61.872" cy="20.856" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M35.266 150.625c18.924 0 34.265-8.89 34.265-19.856v-8.185H1v8.185c0 10.966 15.341 19.856 34.266 19.856z"></path><ellipse cx="35.266" cy="121.962" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M35.266 127.081c18.924 0 34.265-8.889 34.265-19.856v-8.184H1v8.184c0 10.967 15.341 19.856 34.266 19.856z"></path><ellipse cx="35.266" cy="98.418" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M35.266 103.538c18.924 0 34.265-8.89 34.265-19.856v-8.185H1v8.185c0 10.966 15.341 19.856 34.266 19.856z"></path><ellipse cx="35.266" cy="74.875" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="url(#logopaint0_linear)" d="M176.962 126.079c0 14.868-20.8 26.921-46.458 26.921-25.658 0-46.458-12.053-46.458-26.921 0-14.868 20.8-26.921 46.458-26.921 25.658 0 46.458 12.053 46.458 26.921z"></path><path fill="url(#logopaint1_linear)" d="M84.046 113.242h92.916v11.097H84.046v-11.097z"></path><ellipse cx="130.503" cy="112.399" fill="url(#logopaint2_linear)" opacity="0.6" rx="46.458" ry="26.921"></ellipse><path fill="url(#logopaint3_linear)" d="M176.962 102.787c0 14.868-20.8 26.921-46.458 26.921-25.658 0-46.458-12.053-46.458-26.921 0-14.868 20.8-26.921 46.458-26.921 25.658 0 46.458 12.053 46.458 26.921z"></path><path fill="url(#logopaint4_linear)" d="M84.046 89.95h92.916v11.098H84.046V89.951z"></path><ellipse cx="130.503" cy="89.107" fill="url(#logopaint5_linear)" opacity="0.6" rx="46.458" ry="26.921"></ellipse><path fill="url(#logopaint6_linear)" d="M176.961 79.495c0 14.868-20.8 26.921-46.458 26.921-25.658 0-46.458-12.053-46.458-26.92 0-14.869 20.8-26.922 46.458-26.922 25.658 0 46.458 12.053 46.458 26.921z"></path><path fill="url(#logopaint7_linear)" d="M84.045 66.659h92.916v11.097H84.045V66.659z"></path><ellipse cx="130.502" cy="65.815" fill="url(#logopaint8_linear)" rx="46.458" ry="26.921"></ellipse><path fill="#819BA7" d="M125.436 57.898l-15.591 23.727 18.478-16.586 8.085 4.608 16.168-20.272-16.168 12.44-10.972-3.917z" opacity="0.5"></path><defs><linearGradient id="logopaint0_linear" x1="84.046" x2="176.962" y1="96.36" y2="96.36" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint1_linear" x1="84.046" x2="176.962" y1="96.36" y2="96.36" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint2_linear" x1="161.266" x2="94.852" y1="75.474" y2="113.223" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="1" stop-color="#fff"></stop></linearGradient><linearGradient id="logopaint3_linear" x1="84.046" x2="176.962" y1="73.068" y2="73.068" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint4_linear" x1="84.046" x2="176.962" y1="73.068" y2="73.068" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint5_linear" x1="161.266" x2="94.852" y1="52.182" y2="89.931" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="1" stop-color="#fff"></stop></linearGradient><linearGradient id="logopaint6_linear" x1="84.045" x2="176.961" y1="49.776" y2="49.776" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint7_linear" x1="84.045" x2="176.961" y1="49.776" y2="49.776" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint8_linear" x1="161.893" x2="101.783" y1="45.146" y2="86.643" gradientUnits="userSpaceOnUse"><stop stop-color="#E3E8EF"></stop><stop offset="1" stop-color="#F8FAFC"></stop></linearGradient></defs></svg></div><div class="container info"><div class="content"><h4>Prisma&#x27;s Data Guide</h4><p>A growing library of articles focused on making databases more approachable.</p></div><div class="love">Made with ❤️ by <a href="https://www.prisma.io" target="_blank">Prisma</a></div></div></div></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/serverless/traditional-vs-serverless-databases";/*]]>*/</script><script id="gatsby-chunk-mapping">/*<![CDATA[*/window.___chunkMapping={"polyfill":["/polyfill-708f5fd92f58c27daf4b.js"],"app":["/app-c7044d5daf7d47198f21.js"],"component---src-layouts-article-layout-tsx":["/component---src-layouts-article-layout-tsx-9059e882c0a657cdd977.js"],"component---src-pages-404-tsx":["/component---src-pages-404-tsx-0182ef56b4f116116eb2.js"]};/*]]>*/</script><script src="/dataguide/polyfill-708f5fd92f58c27daf4b.js" nomodule=""></script><script src="/dataguide/component---src-layouts-article-layout-tsx-9059e882c0a657cdd977.js" async=""></script><script src="/dataguide/commons-6a03fed22e77ce84b1e9.js" async=""></script><script src="/dataguide/styles-e9d24b1846c7d6eb9685.js" async=""></script><script src="/dataguide/app-c7044d5daf7d47198f21.js" async=""></script><script src="/dataguide/framework-260c11da1cc53725f6de.js" async=""></script><script src="/dataguide/webpack-runtime-1cbb84544ff5c92b5a82.js" async=""></script></body></html>