<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8"/><meta http-equiv="x-ua-compatible" content="ie=edge"/><style data-href="/dataguide/styles.12e0ce55f726c5e82112.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 2.30.3"/><title data-react-helmet="true">What is an ORM?</title><link data-react-helmet="true" rel="canonical" href="https://www.prisma.io/dataguide/types/relational/what-is-an-orm"/><link data-react-helmet="true" rel="icon" href="data:image/png;base64,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"/><meta data-react-helmet="true" name="viewport" content="width=device-width, initial-scale=1"/><meta data-react-helmet="true" name="description" content="What are ORMs and how are they useful? In this guide, we&#x27;ll explain what ORMs are and why they are helpful for many projects."/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:site" content="@prisma"/><meta data-react-helmet="true" name="twitter:title" content="What is an ORM?"/><meta data-react-helmet="true" name="twitter:description" content="What are ORMs and how are they useful? In this guide, we&#x27;ll explain what ORMs are and why they are helpful for many projects."/><meta data-react-helmet="true" name="twitter:creator" content="@prisma"/><meta data-react-helmet="true" name="twitter:image" content="https://www.prisma.io/dataguide/social/docs-social.png"/><meta data-react-helmet="true" property="og:url" content="https://www.prisma.io/dataguide/types/relational/what-is-an-orm"/><meta data-react-helmet="true" property="og:title" content="What is an ORM?"/><meta data-react-helmet="true" property="og:description" content="What are ORMs and how are they useful? In this guide, we&#x27;ll explain what ORMs are and why they are helpful for many projects."/><meta data-react-helmet="true" property="og:site_name" content="Prisma&#x27;s Data Guide"/><meta data-react-helmet="true" property="og:type" content="website"/><meta data-react-helmet="true" property="og:image" content="https://www.prisma.io/dataguide/social/docs-social.png"/><meta data-react-helmet="true" property="og:image:alt" content="Prisma&#x27;s Data Guide"/><meta data-react-helmet="true" property="og:image:type" content="image/png"/><meta data-react-helmet="true" property="og:image:width" content="1200"/><meta data-react-helmet="true" property="og:image:height" content="630"/><style data-styled="hSmnUr jGDNMO kHZfpW fmxOwh cVekrW bcfNLx cyqhKw jwmlip kHPKUM kpaIAg bWNIOR gUpGFq lmFDlL hsjqRs keHlXB kkkHOW kBqHOD kbPCxh kgNgFY dloams hpWsEz clttwx eeOKop kqMtkp jOTGAl CUX eCwksK jcIJnf fhjAMq bzaeW" data-styled-version="4.4.1">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</style><style data-styled="kSeunM" data-styled-version="4.4.1">
/* sc-component-id: sc-gqjmRU */
.kSeunM{max-width:880px;width:880px;margin:0.5rem 0 1rem 0;position:relative;z-index:100;} @media (min-width:0px) and (max-width:1024px){.kSeunM{width:100%;max-width:100%;}}</style><link rel="sitemap" type="application/xml" href="/dataguide/sitemap.xml"/><script>window.dataLayer = window.dataLayer || [];window.dataLayer.push({"website":"dataguide"}); (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-KCGZPWB');</script><link as="script" rel="preload" href="/dataguide/webpack-runtime-c8c115c7c8ee38ea6769.js"/><link as="script" rel="preload" href="/dataguide/framework-260c11da1cc53725f6de.js"/><link as="script" rel="preload" href="/dataguide/app-32afb110867b1f126904.js"/><link as="script" rel="preload" href="/dataguide/styles-e9d24b1846c7d6eb9685.js"/><link as="script" rel="preload" href="/dataguide/commons-e79634f2f11ac05f071b.js"/><link as="script" rel="preload" href="/dataguide/component---src-layouts-article-layout-tsx-eada2f12673f65eef753.js"/><link as="fetch" rel="preload" href="/dataguide/page-data/types/relational/what-is-an-orm/page-data.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/dataguide/page-data/sq/d/3649180363.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/dataguide/page-data/sq/d/3662830458.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/dataguide/page-data/sq/d/3740740500.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/dataguide/page-data/app-data.json" crossorigin="anonymous"/></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KCGZPWB" height="0" width="0" style="display: none; visibility: hidden" aria-hidden="true"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div class="banner__BannerWrapper-mvhat3-0 hSmnUr"><div class="banner__BannerText-mvhat3-1 jGDNMO"><a href="/data-platform">Manage your application data in one place with the <strong>Prisma Data Platform</strong>. Learn more -&gt;</a></div></div><div class="header__HeaderWrapper-sc-1ohc4aq-0 kHZfpW"><div class="container"><div class="header__HeaderNav-sc-1ohc4aq-1 fmxOwh"><div style="display:flex"><a style="color:white;text-decoration:none;display:flex;align-items:center" href="/dataguide/"><div class="header__LogoContainer-sc-1ohc4aq-3 cVekrW"><svg width="64" height="64" viewBox="0 0 64 64" fill="none" xmlns="http://www.w3.org/2000/svg" class="Logo-fvvsj4-0 bcfNLx"><rect width="64" height="64" rx="12" fill="url(#paint0_linear)"></rect><path fill-rule="evenodd" clip-rule="evenodd" d="M49.0186 46.0734L27.3284 52.4484C26.6657 52.6434 26.0306 52.0737 26.1699 51.4096L33.9186 14.5324C34.0635 13.8428 35.0227 13.7333 35.3254 14.3719L49.6725 44.648C49.9431 45.2191 49.6344 45.8926 49.0186 46.0734ZM52.7382 44.5696L36.1262 9.51376C35.7096 8.63739 34.8401 8.05838 33.8548 8.00476C32.8439 7.94626 31.9382 8.43076 31.4273 9.25539L13.4107 38.2542C12.8526 39.158 12.8635 40.2725 13.4424 41.1653L22.2492 54.7224C22.7741 55.5316 23.6835 56 24.6288 56C24.8967 56 25.1661 55.9625 25.4311 55.8845L50.9948 48.371C51.7779 48.1407 52.4182 47.5902 52.7533 46.8605C53.0873 46.1304 53.082 45.2949 52.7382 44.5696Z" fill="#EBF4FF"></path><defs><linearGradient id="paint0_linear" x1="32" y1="0" x2="32" y2="64" gradientUnits="userSpaceOnUse"><stop stop-color="#667EEA"></stop><stop offset="1" stop-color="#4C51BF"></stop></linearGradient></defs></svg><span>Prisma&#x27;s Data Guide</span></div></a></div></div><div class="sc-htpNat cyqhKw"><div class="header__DocsMobileButton-sc-1ohc4aq-4 jwmlip">Menu</div></div><div class="header__PrismaLink-sc-1ohc4aq-6 kHPKUM">Modern Database Access for TypeScript &amp; Node.js<a href="https://www.prisma.io" target="_blank" class="header__PrismaButton-sc-1ohc4aq-7 kpaIAg">Explore Prisma</a></div></div></div><div class="layout__Wrapper-brko2w-0 bWNIOR"><section class="layout__NotMobile-brko2w-2 gUpGFq"><div><aside class="sidebar__SidebarContainer-sy974m-0 lmFDlL"><div><div></div><div id="sidebar-container" class="sc-bwzfXH hsjqRs"><ul class="sidebar__List-sy974m-1 keHlXB"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/intro"><span>Introduction to databases</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/intro/what-are-databases" href="/dataguide/intro/what-are-databases"><span>What are databases?</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/intro/comparing-database-types" href="/dataguide/intro/comparing-database-types"><span>Comparing database types: how database types evolved to meet different needs</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/intro/intro-to-schemas" href="/dataguide/intro/intro-to-schemas"><span>Introduction to database schemas</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/intro/database-glossary" href="/dataguide/intro/database-glossary"><span>Glossary of common database terminology</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/datamodeling"><span>Data Modeling</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/intro-dont-panic" href="/dataguide/datamodeling/intro-dont-panic"><span>Intro (Don&#x27;t Panic)</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/know-your-problem-space" href="/dataguide/datamodeling/know-your-problem-space"><span>Know Your Problem Space</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/tables-tuples-types" href="/dataguide/datamodeling/tables-tuples-types"><span>Tables, Tuples, Types</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/correctness-constraints" href="/dataguide/datamodeling/correctness-constraints"><span>Correctness and Constraints</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/making-connections" href="/dataguide/datamodeling/making-connections"><span>Making Connections</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/functional-units" href="/dataguide/datamodeling/functional-units"><span>Functional Units</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/datamodeling/in-vivo" href="/dataguide/datamodeling/in-vivo"><span>In Vivo: Information Ecosystems</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/types"><span>Database types</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/types/relational-vs-document-databases" href="/dataguide/types/relational-vs-document-databases"><span>Comparing relational and document databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/types/relational" href="/dataguide/types/relational"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Relational Databases</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD has-border"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    last-level"><a aria-current="page" class="active-item active-item" id="/dataguide/types/relational/what-is-an-orm" href="/dataguide/types/relational/what-is-an-orm"><span>What is an ORM?</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    last-level"><a class="hh" id="/dataguide/types/relational/comparing-sql-query-builders-and-orms" href="/dataguide/types/relational/comparing-sql-query-builders-and-orms"><span>Comparing SQL, query builders, and ORMs</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    last-level"><a class="hh" id="/dataguide/types/relational/what-are-database-migrations" href="/dataguide/types/relational/what-are-database-migrations"><span>What are database migrations?</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    last-level"><a class="hh" id="/dataguide/types/relational/migration-strategies" href="/dataguide/types/relational/migration-strategies"><span>Strategies for deploying database migrations</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    last-level"><a class="hh" id="/dataguide/types/relational/expand-and-contract-pattern" href="/dataguide/types/relational/expand-and-contract-pattern"><span>Using the expand and contract pattern for schema changes</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    last-level"><a class="hh" id="/dataguide/types/relational/infrastructure-architecture" href="/dataguide/types/relational/infrastructure-architecture"><span>Comparing common database infrastructure patterns</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    last-level"></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/types/document" href="/dataguide/types/document"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Document Databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/postgresql"><span>PostgreSQL</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/benefits-of-postgresql" href="/dataguide/postgresql/benefits-of-postgresql"><span>The benefits of PostgreSQL</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/getting-to-know-postgresql" href="/dataguide/postgresql/getting-to-know-postgresql"><span>Getting to know PostgreSQL</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/5-ways-to-host-postgresql" href="/dataguide/postgresql/5-ways-to-host-postgresql"><span>5 ways to host PostgreSQL databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/setting-up-a-local-postgresql-database" href="/dataguide/postgresql/setting-up-a-local-postgresql-database"><span>Setting up a local PostgreSQL database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/setting-up-postgresql-on-rds" href="/dataguide/postgresql/setting-up-postgresql-on-rds"><span>How to configure a PostgreSQL database on RDS</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/connecting-to-postgresql-databases" href="/dataguide/postgresql/connecting-to-postgresql-databases"><span>Connecting to PostgreSQL databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/authentication-and-authorization" href="/dataguide/postgresql/authentication-and-authorization"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Authentication and authorization</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/create-and-delete-databases-and-tables" href="/dataguide/postgresql/create-and-delete-databases-and-tables"><span>How to create and delete databases and tables in PostgreSQL</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/introduction-to-data-types" href="/dataguide/postgresql/introduction-to-data-types"><span>An introduction to PostgreSQL data types</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/column-and-table-constraints" href="/dataguide/postgresql/column-and-table-constraints"><span>An introduction to PostgreSQL column and table constraints</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/date-types" href="/dataguide/postgresql/date-types"><span>Working with dates in PostgreSQL</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/inserting-and-modifying-data" href="/dataguide/postgresql/inserting-and-modifying-data"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Inserting and modifying data</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/reading-and-querying-data" href="/dataguide/postgresql/reading-and-querying-data"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Reading and querying data</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/postgresql/short-guides" href="/dataguide/postgresql/short-guides"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Short guides</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/mysql"><span>MySQL</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/5-ways-to-host-mysql" href="/dataguide/mysql/5-ways-to-host-mysql"><span>5 ways to host MySQL databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/setting-up-a-local-mysql-database" href="/dataguide/mysql/setting-up-a-local-mysql-database"><span>Setting up a local MySQL database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/connecting-to-mysql-databases" href="/dataguide/mysql/connecting-to-mysql-databases"><span>Connecting to MySQL databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/authentication-and-authorization" href="/dataguide/mysql/authentication-and-authorization"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Authentication and authorization</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/create-and-delete-databases-and-tables" href="/dataguide/mysql/create-and-delete-databases-and-tables"><span>How to create and delete databases and tables in MySQL</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/introduction-to-data-types" href="/dataguide/mysql/introduction-to-data-types"><span>An introduction to MySQL data types</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/column-and-table-constraints" href="/dataguide/mysql/column-and-table-constraints"><span>An introduction to MySQL column and table constraints</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/inserting-and-modifying-data" href="/dataguide/mysql/inserting-and-modifying-data"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Inserting and modifying data</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/reading-and-querying-data" href="/dataguide/mysql/reading-and-querying-data"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Reading and querying data</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/tools" href="/dataguide/mysql/tools"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Tools and utilities</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mysql/short-guides" href="/dataguide/mysql/short-guides"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Short guides</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/sqlite"><span>SQLite</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/setting-up-a-local-sqlite-database" href="/dataguide/sqlite/setting-up-a-local-sqlite-database"><span>Setting up a local SQLite database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/importing-and-exporting-data-in-sqlite" href="/dataguide/sqlite/importing-and-exporting-data-in-sqlite"><span>Importing and exporting data in SQLite</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/creating-and-deleting-databases-and-tables" href="/dataguide/sqlite/creating-and-deleting-databases-and-tables"><span>Creating and deleting databases and tables with SQLite</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/inserting-and-deleting-data" href="/dataguide/sqlite/inserting-and-deleting-data"><span>Inserting and deleting data with SQLite</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/basic-select" href="/dataguide/sqlite/basic-select"><span>How to perform basic queries with `SELECT` with SQLite</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/sqlite/update-data" href="/dataguide/sqlite/update-data"><span>How to update existing data with SQLite</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/mssql"><span>Microsoft SQL Server</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mssql/setting-up-a-local-sql-server-database" href="/dataguide/mssql/setting-up-a-local-sql-server-database"><span>Setting up a local SQL Server database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/mongodb"><span>MongoDB</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/what-is-mongodb" href="/dataguide/mongodb/what-is-mongodb"><span>What is MongoDB?</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/setting-up-a-local-mongodb-database" href="/dataguide/mongodb/setting-up-a-local-mongodb-database"><span>Setting up a local MongoDB database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/connecting-to-mongodb" href="/dataguide/mongodb/connecting-to-mongodb"><span>Connecting to MongoDB databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/mongodb-atlas-setup" href="/dataguide/mongodb/mongodb-atlas-setup"><span>Introduction to provisioning MongoDB Atlas</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/configuring-mongodb-user-accounts-and-authentication" href="/dataguide/mongodb/configuring-mongodb-user-accounts-and-authentication"><span>How to manage users and authentication in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/authorization-and-privileges" href="/dataguide/mongodb/authorization-and-privileges"><span>How to manage authorization and privileges in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/creating-dbs-and-collections" href="/dataguide/mongodb/creating-dbs-and-collections"><span>How to manage databases and collections in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/managing-documents" href="/dataguide/mongodb/managing-documents"><span>How to manage documents in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/querying-documents" href="/dataguide/mongodb/querying-documents"><span>How to query and filter documents in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/mongodb-datatypes" href="/dataguide/mongodb/mongodb-datatypes"><span>Introduction to MongoDB data types</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/mongodb-indexes" href="/dataguide/mongodb/mongodb-indexes"><span>Introduction to MongoDB indexes</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/mongodb-transactions" href="/dataguide/mongodb/mongodb-transactions"><span>Introduction to MongoDB transactions</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/connection-uris" href="/dataguide/mongodb/connection-uris"><span>Introduction to MongoDB connection URIs</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/working-with-dates" href="/dataguide/mongodb/working-with-dates"><span>Working with dates and times in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/mongodb-encryption" href="/dataguide/mongodb/mongodb-encryption"><span>How MongoDB encrypts data</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/mongodb-database-tools" href="/dataguide/mongodb/mongodb-database-tools"><span>Introduction to MongoDB database tools &amp; utilities</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/mongodb/mongodb-sorting" href="/dataguide/mongodb/mongodb-sorting"><span>How to sort query results in MongoDB</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/database-tools"><span>Database tools</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/database-tools/top-nodejs-orms-query-builders-and-database-libraries" href="/dataguide/database-tools/top-nodejs-orms-query-builders-and-database-libraries"><span>Top 11 Node.js ORMs, Query Builders &amp; Database Libraries in 2022</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/database-tools/evaluating-type-safety-in-the-top-8-typescript-orms" href="/dataguide/database-tools/evaluating-type-safety-in-the-top-8-typescript-orms"><span>Top 8 TypeScript ORMs, Query Builders, &amp; Database Libraries: Evaluating Type Safety</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/database-tools/connection-pooling" href="/dataguide/database-tools/connection-pooling"><span>What is connection pooling and how does it work?</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/managing-databases"><span>Managing databases</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/database-troubleshooting" href="/dataguide/managing-databases/database-troubleshooting"><span>Troubleshooting Database Outages and Connection Issues</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/how-to-spot-bottlenecks-in-performance" href="/dataguide/managing-databases/how-to-spot-bottlenecks-in-performance"><span>How to Spot Bottlenecks in Performance</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/syncing-development-databases-between-team-members" href="/dataguide/managing-databases/syncing-development-databases-between-team-members"><span>Syncing Development Databases Between Team Members</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/database-replication" href="/dataguide/managing-databases/database-replication"><span class="collapse-title"><button aria-label="collapse" class="item-collapser"><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button>Database Replication</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/introduction-to-OLAP-OLTP" href="/dataguide/managing-databases/introduction-to-OLAP-OLTP"><span>Introduction to OLAP and OLTP</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/microservices-vs-monoliths" href="/dataguide/managing-databases/microservices-vs-monoliths"><span>How microservices and monoliths impact the database</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/introduction-database-caching" href="/dataguide/managing-databases/introduction-database-caching"><span>Introduction to database caching</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/testing-in-production" href="/dataguide/managing-databases/testing-in-production"><span>Introduction to testing in production</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/managing-databases/backup-considerations" href="/dataguide/managing-databases/backup-considerations"><span>Introduction to database backup considerations</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/serverless"><span>Serverless architecture</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/serverless/what-is-serverless" href="/dataguide/serverless/what-is-serverless"><span>What is serverless?</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/serverless/serverless-comparison" href="/dataguide/serverless/serverless-comparison"><span>Top 13 serverless computing and database providers</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/serverless/serverless-challenges" href="/dataguide/serverless/serverless-challenges"><span>Introduction to common serverless challenges</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/serverless/traditional-vs-serverless-databases" href="/dataguide/serverless/traditional-vs-serverless-databases"><span>Traditional databases vs serverless databases</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/serverless/serverless-glossary" href="/dataguide/serverless/serverless-glossary"><span>Serverless Glossary</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><a class="hh" id="/dataguide/just-for-fun"><span>Just for fun</span></a><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW    "><a class="hh" id="/dataguide/just-for-fun/us-most-popular-databases-by-states" href="/dataguide/just-for-fun/us-most-popular-databases-by-states"><span>The United States&#x27; Most Popular Databases by state going into 2022</span></a></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "><ul class="treeNode__List-sc-10fh1og-0 kBqHOD"><li class="treeNode__ListItem-sc-10fh1og-1 kkkHOW  top-level  "></li></ul></li></ul></li></ul></div></div></aside></div></section><article class="sc-gqjmRU kSeunM"><div class="layout__MaxWidth-brko2w-1 kbPCxh"><section class="top-section"><div class="topSection__TopSectionWrapper-sc-1dezfo1-0 kgNgFY"><h2 class="parentTitleComp__BreadcrumbTitle-sc-1f4ly1o-0 dloams"><span><a href="/dataguide/types">Database types<!-- --> </a> / </span><span><a href="/dataguide/types/relational">Relational Databases<!-- --> </a></span></h2><h1 class="topSection__MainTitle-sc-1dezfo1-1 hpWsEz">What is an ORM?</h1><div><h2 class="toc__ChapterTitle-vklla6-0 clttwx">CONTENT</h2><ul class="list"><li><a href="#introduction">Introduction</a></li><li><a href="#what-is-an-orm">What is an ORM?</a></li><li><a href="#do-i-need-an-orm">Do I need an ORM?</a></li><li><a href="#conclusion">Conclusion</a></li></ul></div></div><div class="socialShareSection__SocialWrapper-cg5jms-0 eeOKop"><span>Share on</span><div class="buttons"><a href="https://twitter.com/intent/tweet?text=I%27ve%20found%20this%20page%20on%20%40prisma%27s%20%23DataGuide%20useful%21%20https://www.prisma.io/dataguide/types/relational/what-is-an-orm" target="_blank"><svg width="20" height="20" viewBox="0 0 20 20" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M4 0C1.79086 0 0 1.79086 0 4V16C0 18.2091 1.79086 20 4 20H16C18.2091 20 20 18.2091 20 16V4C20 1.79086 18.2091 0 16 0H4ZM14.5864 11.7956C15.2274 10.5549 15.529 9.15425 15.4582 7.74675C16.0131 7.46224 16.4447 6.9697 16.6667 6.36758C16.2036 6.60035 15.7052 6.74703 15.1939 6.80103C15.7565 6.48055 16.1767 5.94313 16.3646 5.30365C15.8714 5.63744 15.3193 5.86518 14.7407 5.97353C14.3701 5.49839 13.8526 5.17253 13.277 5.05179C12.7014 4.93105 12.1034 5.02294 11.5856 5.31172C11.0678 5.6005 10.6624 6.06819 10.4388 6.63466C10.2152 7.20113 10.1873 7.8311 10.36 8.41664C9.33168 8.35852 8.32646 8.07599 7.40927 7.5873C6.49209 7.0986 5.68333 6.4146 5.03525 5.57948C4.72018 6.15692 4.61547 6.83362 4.74035 7.48517C4.86524 8.13673 5.21133 8.71935 5.715 9.12592C5.35333 9.13645 4.99343 9.06939 4.6576 8.9289C4.68147 9.55258 4.90735 10.1494 5.29834 10.6218C5.68932 11.0941 6.2223 11.4142 6.81017 11.5296C6.43052 11.647 6.03044 11.674 5.63948 11.6084C5.79989 12.1013 6.09069 12.5368 6.47829 12.8645C6.86588 13.1923 7.33444 13.3989 7.82981 13.4605C6.79012 14.3121 5.48561 14.7331 4.16667 14.6426C5.30811 15.3962 6.62621 15.8078 7.97677 15.8322C9.32732 15.8566 10.6583 15.4929 11.8241 14.781C12.9898 14.069 13.9455 13.0362 14.5864 11.7956Z" fill="#A0AEC0"></path></svg></a></div></div></section><section><h2 id="introduction" style="position:relative"><a href="#introduction" aria-label="introduction permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Introduction</h2><p class="paragraph">What is an ORM and why are they so common when working with database?  If you are new to programming applications backed by relational databases, you may have come across the term ORM during your research.  In this guide, we&#x27;ll briefly cover what an ORM is and how they can be helpful.</p><div class="sc-ifAKCX kqMtkp">RELATED ON PRISMA.IO<p class="paragraph"><a href="https://www.prisma.io/docs/concepts/overview/what-is-prisma">Prisma</a> is an ORM focused on making it easy for Node.js and TypeScript applications to work with databases.  You can learn more about what Prisma offers in our <a href="https://www.prisma.io/docs/concepts/overview/why-prisma">Why Prisma? page</a>.</p><div class="prismaOutlinks__LogoWrapper-sc-4gmc34-0 jOTGAl"><span class="icon"><svg width="20" height="24" viewBox="0 0 20 24" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M18.0093 19.0367L7.16418 22.2242C6.83286 22.3217 6.51532 22.0369 6.58494 21.7048L10.4593 3.2662C10.5317 2.92139 11.0114 2.86664 11.1627 3.18595L18.3363 18.324C18.4716 18.6096 18.3172 18.9463 18.0093 19.0367ZM19.8691 18.2848L11.5631 0.756881C11.3548 0.318693 10.9201 0.0291921 10.4274 0.00237954C9.92194 -0.0268705 9.46911 0.21538 9.21364 0.627694L0.205335 15.1271C-0.0737223 15.579 -0.0682506 16.1362 0.221184 16.5827L4.62458 23.3612C4.88704 23.7658 5.34175 24 5.81439 24C5.94836 24 6.08307 23.9813 6.21553 23.9423L18.9974 20.1855C19.3889 20.0704 19.7091 19.7951 19.8767 19.4302C20.0436 19.0652 20.041 18.6474 19.8691 18.2848Z" fill="#63B3ED"></path></svg></span>Prisma is an open-source database toolkit for Typescript and Node.js that aims to make app developers more productive and confident when working with databases.</div></div></section><section><h2 id="what-is-an-orm" style="position:relative"><a href="#what-is-an-orm" aria-label="what is an orm permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>What is an ORM?</h2><p class="paragraph">An <a href="/dataguide/intro/database-glossary#orm">ORM</a>, or Object Relational Mapper, is a piece of software designed to translate between the data representations used by databases and those used in object-oriented programming.  Basically, these two ways of working with data don&#x27;t naturally fit together, so an ORM attempts to bridge the gap between the two systems&#x27; data designs.</p><p class="paragraph">From a developer&#x27;s perspective, an ORM allows you to work with database-backed data using the same object-oriented structures and mechanisms you&#x27;d use for any type of internal data.  The promise of ORMs is that you won&#x27;t need to rely on special techniques or necessarily learn a new querying language like <a href="/dataguide/intro/database-glossary#sql">SQL</a> to be productive with your data.</p><p class="paragraph">In general, ORMs serve as an abstraction layer between the application and the database.  They attempt to increase developer productivity by removing the need for boilerplate code and avoiding the use of awkward techniques that might break the idioms and ergonomics that you expect from your language of choice.</p></section><section><h2 id="do-i-need-an-orm" style="position:relative"><a href="#do-i-need-an-orm" aria-label="do i need an orm permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Do I need an ORM?</h2><p class="paragraph">While ORMs can be helpful, it&#x27;s important to view them as a tool.  They won&#x27;t be useful in every scenario and there may be trade-offs you need to account for.</p><p class="paragraph">In general, an ORM might be a good fit if you are using many object-oriented features of your language to manage a lot of state.  The implications of managing state encapsulated in objects that have complex inheritance relationships, for instance, may be difficult to account for manually.  They can also help get your project off the ground easier and can manage changes in your data structure through functionality like schema migration.</p><p class="paragraph">While ORMs are often useful, they&#x27;re not perfect.  Sometimes the level of abstraction introduced by an ORM can make debugging difficult.  There are also times when the representation the ORM uses to translate between the database and your application might not be completely accurate or might leak details of your internal implementation.  These may be problems for certain use cases.</p><p class="paragraph">It&#x27;s important to understand what your project&#x27;s requirements are and how you want to spend your resources when building your software.  ORMs are a tool that can help you build database-backed applications more easily, but you&#x27;ll have to decide for yourself if add value for your project.</p></section><section><h2 id="conclusion" style="position:relative"><a href="#conclusion" aria-label="conclusion permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Conclusion</h2><p class="paragraph">In this guide, we took a brief look at what ORMs are and how they can be useful.  In general, it&#x27;s a good idea to ask yourself early on whether an ORM would help your project.  Evaluating the trade-offs can be a good exercise to help you understand how you wish to focus your efforts.</p><p class="paragraph">To take a look at how ORMs compare to other ways of interacting with databases, take a look at our <a href="/dataguide/types/relational/comparing-sql-query-builders-and-orms">comparison of SQL, query builders, and ORMs</a>.</p><div class="sc-ifAKCX kqMtkp">RELATED ON PRISMA.IO<p class="paragraph"><a href="https://www.prisma.io/docs/concepts/overview/what-is-prisma">Prisma</a> is an ORM focused on making it easy for Node.js and TypeScript applications to work with databases.  You can learn more about what Prisma offers in our <a href="https://www.prisma.io/docs/concepts/overview/why-prisma">Why Prisma? page</a>.</p><div class="prismaOutlinks__LogoWrapper-sc-4gmc34-0 jOTGAl"><span class="icon"><svg width="20" height="24" viewBox="0 0 20 24" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M18.0093 19.0367L7.16418 22.2242C6.83286 22.3217 6.51532 22.0369 6.58494 21.7048L10.4593 3.2662C10.5317 2.92139 11.0114 2.86664 11.1627 3.18595L18.3363 18.324C18.4716 18.6096 18.3172 18.9463 18.0093 19.0367ZM19.8691 18.2848L11.5631 0.756881C11.3548 0.318693 10.9201 0.0291921 10.4274 0.00237954C9.92194 -0.0268705 9.46911 0.21538 9.21364 0.627694L0.205335 15.1271C-0.0737223 15.579 -0.0682506 16.1362 0.221184 16.5827L4.62458 23.3612C4.88704 23.7658 5.34175 24 5.81439 24C5.94836 24 6.08307 23.9813 6.21553 23.9423L18.9974 20.1855C19.3889 20.0704 19.7091 19.7951 19.8767 19.4302C20.0436 19.0652 20.041 18.6474 19.8691 18.2848Z" fill="#63B3ED"></path></svg></span>Prisma is an open-source database toolkit for Typescript and Node.js that aims to make app developers more productive and confident when working with databases.</div></div></section><section><div class="authorDetails__AuthorInfoWrapper-sc-1aj5thl-0 CUX"><span class="about">About the Author(s)</span><div class="author-item"><img alt="Justin Ellingwood" src="https://github.com/imchairmanm.png"/><div><h3 class="name">Justin Ellingwood</h3>Justin has been writing about databases, Linux, infrastructure, and developer tools since 2013.  He currently lives in Berlin with his wife and two rabbits.  He doesn&#x27;t usually have to write in the third person, which is a relief for all parties involved.</div></div></div></section><div class="nextPrevious__NextPreviousWrapper-sc-5jz07g-0 eCwksK"><div class="previous"><div class="text"><span class="direction">Previous</span><a href="/dataguide/types/relational-vs-document-databases"><span class="icon"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="#3182CE" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><line x1="19" y1="12" x2="5" y2="12"></line><polyline points="12 19 5 12 12 5"></polyline></svg></span><div class="title">Comparing relational and document databases</div></a></div></div><div class="next"><div class="text"><span class="direction">Next</span><a href="/dataguide/types/relational/comparing-sql-query-builders-and-orms"><div class="title">Comparing SQL, query builders, and ORMs</div><span class="icon"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="#3182CE" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><line x1="5" y1="12" x2="19" y2="12"></line><polyline points="12 5 19 12 12 19"></polyline></svg></span></a></div></div></div><div class="pageBottom__PageBottomWrapper-bhhqu2-0 jcIJnf"><div></div><a href="https://github.com/prisma/dataguide/tree/master/content/03-types/02-relational/01-what-is-an-orm.mdx" class="edit-git">Edit this page on GitHub</a></div></div></article></div><div class="footer__FooterWrapper-sc-9drt3p-0 fhjAMq"><div class="push-right"><div class="container"><div class="content"><div class="newsletter__NewsLetterWrapper-sc-1b14zu9-0 bzaeW"><h2>Get notified of new articles</h2><p>Sign up to get notified by email when new content is added to Prisma&#x27;s Data Guide.</p><form class="email"><label for="email" aria-label="Insert your email"><input type="text" id="email" placeholder="your@email.com" value=""/></label><button disabled="" type="submit">Subscribe <svg width="20" height="20" viewBox="0 0 20 20" fill="none" xmlns="http://www.w3.org/2000/svg"><circle cx="10" cy="10" r="10" fill="#4C51BF"></circle><path d="M8 6L12.2218 10.2218L8 14.4435" stroke="#F9F9F9" stroke-width="2"></path></svg></button></form></div></div><svg xmlns="http://www.w3.org/2000/svg" width="177" height="153" fill="none" viewBox="0 0 177 153"><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M61.874 96.606c18.924 0 34.265-8.89 34.265-19.856v-8.185H27.608v8.185c0 10.966 15.341 19.856 34.266 19.856z"></path><ellipse cx="61.873" cy="67.943" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M61.874 73.063c18.924 0 34.265-8.89 34.265-19.857v-8.184H27.608v8.184c0 10.967 15.341 19.856 34.266 19.856z"></path><ellipse cx="61.873" cy="44.4" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M61.873 49.519c18.924 0 34.265-8.89 34.265-19.856v-8.185h-68.53v8.185c0 10.966 15.34 19.856 34.265 19.856z"></path><ellipse cx="61.872" cy="20.856" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M35.266 150.625c18.924 0 34.265-8.89 34.265-19.856v-8.185H1v8.185c0 10.966 15.341 19.856 34.266 19.856z"></path><ellipse cx="35.266" cy="121.962" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M35.266 127.081c18.924 0 34.265-8.889 34.265-19.856v-8.184H1v8.184c0 10.967 15.341 19.856 34.266 19.856z"></path><ellipse cx="35.266" cy="98.418" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" d="M35.266 103.538c18.924 0 34.265-8.89 34.265-19.856v-8.185H1v8.185c0 10.966 15.341 19.856 34.266 19.856z"></path><ellipse cx="35.266" cy="74.875" fill="#F8FAFC" stroke="#CDD5DF" stroke-dasharray="8 8" stroke-width="2" rx="34.266" ry="19.856"></ellipse><path fill="url(#logopaint0_linear)" d="M176.962 126.079c0 14.868-20.8 26.921-46.458 26.921-25.658 0-46.458-12.053-46.458-26.921 0-14.868 20.8-26.921 46.458-26.921 25.658 0 46.458 12.053 46.458 26.921z"></path><path fill="url(#logopaint1_linear)" d="M84.046 113.242h92.916v11.097H84.046v-11.097z"></path><ellipse cx="130.503" cy="112.399" fill="url(#logopaint2_linear)" opacity="0.6" rx="46.458" ry="26.921"></ellipse><path fill="url(#logopaint3_linear)" d="M176.962 102.787c0 14.868-20.8 26.921-46.458 26.921-25.658 0-46.458-12.053-46.458-26.921 0-14.868 20.8-26.921 46.458-26.921 25.658 0 46.458 12.053 46.458 26.921z"></path><path fill="url(#logopaint4_linear)" d="M84.046 89.95h92.916v11.098H84.046V89.951z"></path><ellipse cx="130.503" cy="89.107" fill="url(#logopaint5_linear)" opacity="0.6" rx="46.458" ry="26.921"></ellipse><path fill="url(#logopaint6_linear)" d="M176.961 79.495c0 14.868-20.8 26.921-46.458 26.921-25.658 0-46.458-12.053-46.458-26.92 0-14.869 20.8-26.922 46.458-26.922 25.658 0 46.458 12.053 46.458 26.921z"></path><path fill="url(#logopaint7_linear)" d="M84.045 66.659h92.916v11.097H84.045V66.659z"></path><ellipse cx="130.502" cy="65.815" fill="url(#logopaint8_linear)" rx="46.458" ry="26.921"></ellipse><path fill="#819BA7" d="M125.436 57.898l-15.591 23.727 18.478-16.586 8.085 4.608 16.168-20.272-16.168 12.44-10.972-3.917z" opacity="0.5"></path><defs><linearGradient id="logopaint0_linear" x1="84.046" x2="176.962" y1="96.36" y2="96.36" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint1_linear" x1="84.046" x2="176.962" y1="96.36" y2="96.36" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint2_linear" x1="161.266" x2="94.852" y1="75.474" y2="113.223" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="1" stop-color="#fff"></stop></linearGradient><linearGradient id="logopaint3_linear" x1="84.046" x2="176.962" y1="73.068" y2="73.068" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint4_linear" x1="84.046" x2="176.962" y1="73.068" y2="73.068" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint5_linear" x1="161.266" x2="94.852" y1="52.182" y2="89.931" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="1" stop-color="#fff"></stop></linearGradient><linearGradient id="logopaint6_linear" x1="84.045" x2="176.961" y1="49.776" y2="49.776" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint7_linear" x1="84.045" x2="176.961" y1="49.776" y2="49.776" gradientUnits="userSpaceOnUse"><stop stop-color="#F8FAFC"></stop><stop offset="0.734" stop-color="#CDD5DF"></stop><stop offset="1" stop-color="#99A1AE"></stop></linearGradient><linearGradient id="logopaint8_linear" x1="161.893" x2="101.783" y1="45.146" y2="86.643" gradientUnits="userSpaceOnUse"><stop stop-color="#E3E8EF"></stop><stop offset="1" stop-color="#F8FAFC"></stop></linearGradient></defs></svg></div><div class="container info"><div class="content"><h4>Prisma&#x27;s Data Guide</h4><p>A growing library of articles focused on making databases more approachable.</p></div><div class="love">Made with ❤️ by <a href="https://www.prisma.io" target="_blank">Prisma</a></div></div></div></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/types/relational/what-is-an-orm";/*]]>*/</script><script id="gatsby-chunk-mapping">/*<![CDATA[*/window.___chunkMapping={"polyfill":["/polyfill-708f5fd92f58c27daf4b.js"],"app":["/app-32afb110867b1f126904.js"],"component---src-layouts-article-layout-tsx":["/component---src-layouts-article-layout-tsx-eada2f12673f65eef753.js"],"component---src-pages-404-tsx":["/component---src-pages-404-tsx-0182ef56b4f116116eb2.js"]};/*]]>*/</script><script src="/dataguide/polyfill-708f5fd92f58c27daf4b.js" nomodule=""></script><script src="/dataguide/component---src-layouts-article-layout-tsx-eada2f12673f65eef753.js" async=""></script><script src="/dataguide/commons-e79634f2f11ac05f071b.js" async=""></script><script src="/dataguide/styles-e9d24b1846c7d6eb9685.js" async=""></script><script src="/dataguide/app-32afb110867b1f126904.js" async=""></script><script src="/dataguide/framework-260c11da1cc53725f6de.js" async=""></script><script src="/dataguide/webpack-runtime-c8c115c7c8ee38ea6769.js" async=""></script></body></html>