<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8"/><meta http-equiv="x-ua-compatible" content="ie=edge"/><style data-href="/docs/styles.bd91d5709b8860decaa5.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 2.32.13"/><title data-react-helmet="true">Generating down migrations | Prisma Docs</title><link data-react-helmet="true" rel="canonical" href="https://www.prisma.io/docs/guides/database/developing-with-prisma-migrate/generating-down-migrations"/><link data-react-helmet="true" rel="icon" href="data:image/png;base64,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"/><meta data-react-helmet="true" name="viewport" content="width=device-width, initial-scale=1"/><meta data-react-helmet="true" name="description" content="How to generate down migrations"/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:site" content="@prisma"/><meta data-react-helmet="true" name="twitter:title" content="Generating down migrations"/><meta data-react-helmet="true" name="twitter:description" content="How to generate down migrations"/><meta data-react-helmet="true" name="twitter:creator" content="@prisma"/><meta data-react-helmet="true" name="twitter:image" content="https://www.prisma.io/docs/social/docs-social.png"/><meta data-react-helmet="true" property="og:url" content="https://www.prisma.io/docs/guides/database/developing-with-prisma-migrate/generating-down-migrations"/><meta data-react-helmet="true" property="og:title" content="Generating down migrations"/><meta data-react-helmet="true" property="og:description" content="How to generate down migrations"/><meta data-react-helmet="true" property="og:site_name" content="Prisma"/><meta data-react-helmet="true" property="og:type" content="website"/><meta data-react-helmet="true" property="og:image" content="https://www.prisma.io/docs/social/docs-social.png"/><meta data-react-helmet="true" property="og:image:alt" content="Database tools for modern developers"/><meta data-react-helmet="true" property="og:image:type" content="image/png"/><meta data-react-helmet="true" property="og:image:width" content="1200"/><meta data-react-helmet="true" property="og:image:height" content="630"/><style data-styled="" data-styled-version="5.3.3">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</style><link rel="sitemap" type="application/xml" href="/docs/sitemap.xml"/><script>window.dataLayer = window.dataLayer || [];window.dataLayer.push({"website":"docs"}); (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-KCGZPWB');</script><link as="script" rel="preload" href="/docs/webpack-runtime-a79a71545ca7ea037d9c.js"/><link as="script" rel="preload" href="/docs/framework-5c89213cc2eecdd79e32.js"/><link as="script" rel="preload" href="/docs/app-cffd32f265adc6b77259.js"/><link as="script" rel="preload" href="/docs/styles-7d4153d260c0197f0043.js"/><link as="script" rel="preload" href="/docs/2645202e-1bd79d58a81929c547b4.js"/><link as="script" rel="preload" href="/docs/commons-3a1dee571d9f75b161e1.js"/><link as="script" rel="preload" href="/docs/0e04aa12d481739ffad563c50dc3aa0ca8c758e7-8e45cf0613a383a32ee2.js"/><link as="script" rel="preload" href="/docs/component---src-layouts-article-layout-tsx-2d80d8c29bf510b8b3ed.js"/><link as="fetch" rel="preload" href="/docs/page-data/guides/database/developing-with-prisma-migrate/generating-down-migrations/page-data.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/docs/page-data/sq/d/1321850428.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/docs/page-data/sq/d/239968851.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/docs/page-data/sq/d/3732649728.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/docs/page-data/app-data.json" crossorigin="anonymous"/></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KCGZPWB" height="0" width="0" style="display: none; visibility: hidden" aria-hidden="true"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div class="banner__BannerWrapper-sc-qjw4p6-0 dNJeXp"><div class="banner__BannerText-sc-qjw4p6-1 bwHolG"><a href="/dataplatform">Manage your application data in one place with the <strong>Prisma Data Platform</strong>. Learn more -<!-- -->&gt;</a></div></div><div class="header__HeaderWrapper-sc-1w16195-0 gfCwVK"><div class="header__Container-sc-1w16195-1 bQLcOk"><nav id="navbar" class="Navbar__NavContainer-sc-1kck62g-0 bbIrbi"><div class="logo-container"><a href="/"><svg width="90" height="29" viewBox="0 0 90 29" fill="none" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M0.209637 19.5075C-0.0659575 19.0728 -0.0701211 18.5191 0.198904 18.0802L10.3282 1.55731C10.8916 0.638316 12.252 0.718671 12.7033 1.69759L21.9569 21.7708C22.3002 22.5156 21.905 23.3919 21.1194 23.6276L6.72474 27.946C6.14558 28.1197 5.52155 27.8869 5.19781 27.3762L0.209637 19.5075ZM11.4969 6.38848C11.5945 5.90241 12.2605 5.83232 12.4572 6.28741L18.8402 21.0573C18.9603 21.3354 18.8108 21.6561 18.5205 21.7427L8.57492 24.7116C8.20935 24.8207 7.85916 24.5013 7.93428 24.1272L11.4969 6.38848ZM48.4948 21.6373H51.3226V11.2722H48.4948V21.6373ZM48.3744 8.59301C48.3744 7.67245 48.8878 7.21184 49.9137 7.21184C50.9394 7.21184 51.4527 7.67245 51.4527 8.59301C51.4527 9.03201 51.3244 9.37345 51.068 9.61767C50.8114 9.86189 50.4267 9.98367 49.9137 9.98367C48.8878 9.98367 48.3744 9.52011 48.3744 8.59301ZM87.1709 16.8352L86.0768 16.8722C85.2548 16.8971 84.6429 17.0457 84.2412 17.3174C83.8392 17.5895 83.6386 18.0033 83.6386 18.5598C83.6386 19.3569 84.0959 19.7557 85.0106 19.7557C85.6656 19.7557 86.1897 19.5674 86.5819 19.19C86.9744 18.8132 87.1709 18.3126 87.1709 17.688V16.8352ZM88.0053 21.6377L87.4583 20.2284H87.384C86.908 20.8281 86.4182 21.2439 85.9144 21.4757C85.4109 21.7074 84.7542 21.823 83.9446 21.823C82.9491 21.823 82.1661 21.5388 81.5941 20.9702C81.0226 20.4019 80.7368 19.592 80.7368 18.5411C80.7368 17.4412 81.1214 16.63 81.8907 16.1075C82.6607 15.5853 83.8209 15.2963 85.3723 15.2406L87.1709 15.185V14.7306C87.1709 13.6801 86.633 13.1546 85.5576 13.1546C84.7293 13.1546 83.7558 13.4047 82.6371 13.9056L81.7009 11.9957C82.8938 11.3718 84.2167 11.0592 85.6689 11.0592C87.0596 11.0592 88.1258 11.3623 88.8676 11.9679C89.6091 12.5736 89.98 13.4948 89.98 14.7306V21.6377H88.0053ZM72.4802 21.6377H69.6524V15.5836C69.6524 14.8359 69.527 14.2752 69.2772 13.901C69.0265 13.5271 68.6326 13.3399 68.0948 13.3399C67.3719 13.3399 66.8465 13.606 66.5188 14.1373C66.1911 14.669 66.0275 15.5437 66.0275 16.7612V21.6377H63.1996V11.2725H65.3599L65.74 12.5984H65.8978C66.1757 12.1227 66.5778 11.7502 67.1029 11.4814C67.6283 11.2123 68.231 11.0778 68.9109 11.0778C70.4623 11.0778 71.5128 11.5848 72.0631 12.5984H72.3132C72.5915 12.1162 73.001 11.7423 73.5419 11.4765C74.0827 11.2107 74.6929 11.0778 75.3728 11.0778C76.5471 11.0778 77.4359 11.3793 78.0382 11.9819C78.6409 12.5846 78.9421 13.5504 78.9421 14.8788V21.6377H76.1051V15.5836C76.1051 14.8359 75.9798 14.2752 75.73 13.901C75.4792 13.5271 75.0854 13.3399 74.5475 13.3399C73.8555 13.3399 73.3379 13.5874 72.9945 14.0817C72.6517 14.5763 72.4802 15.361 72.4802 16.4364V21.6377ZM60.17 20.9887C60.9088 20.4325 61.2781 19.6229 61.2781 18.5596C61.2781 18.047 61.1887 17.6047 61.0093 17.2338C60.8299 16.8629 60.5517 16.5355 60.1749 16.251C59.7981 15.9669 59.2046 15.6611 58.3946 15.3334C57.4862 14.9687 56.8976 14.6934 56.6285 14.5081C56.3601 14.3228 56.2252 14.1035 56.2252 13.8498C56.2252 13.3987 56.6426 13.1731 57.477 13.1731C57.9465 13.1731 58.4071 13.2445 58.8582 13.3862C59.3093 13.5286 59.7948 13.7106 60.314 13.9333L61.1668 11.8938C59.9863 11.35 58.7718 11.078 57.5232 11.078C56.2127 11.078 55.2009 11.3297 54.4872 11.8335C53.7729 12.3373 53.416 13.0497 53.416 13.9703C53.416 14.5081 53.5012 14.9612 53.6714 15.3288C53.841 15.6965 54.113 16.0225 54.4872 16.3067C54.8607 16.5912 55.4467 16.9002 56.2438 17.2338C56.8 17.4688 57.2453 17.6744 57.5788 17.8505C57.9128 18.0267 58.1475 18.1845 58.2837 18.3233C58.4195 18.4624 58.4876 18.6431 58.4876 18.8657C58.4876 19.4589 57.9743 19.7555 56.9483 19.7555C56.4478 19.7555 55.8684 19.672 55.2103 19.5054C54.5517 19.3384 53.9601 19.1315 53.4347 18.884V21.2205C53.8983 21.4182 54.3959 21.5681 54.9275 21.6703C55.4591 21.7721 56.1014 21.8231 56.8557 21.8231C58.3266 21.8231 59.4314 21.5449 60.17 20.9887ZM46.9948 11.1612C46.7414 11.1056 46.4232 11.0778 46.0398 11.0778C45.3969 11.0778 44.8021 11.2555 44.2554 11.611C43.708 11.9666 43.2739 12.4347 42.9524 13.0154H42.8136L42.3962 11.2725H40.2546V21.6377H43.0824V16.3624C43.0824 15.528 43.3341 14.8788 43.8376 14.4153C44.3418 13.9517 45.0446 13.7199 45.9472 13.7199C46.2749 13.7199 46.5528 13.751 46.7817 13.8126L46.9948 11.1612ZM31.9317 14.4616H32.8774C33.7613 14.4616 34.4223 14.2871 34.8613 13.9378C35.3003 13.5888 35.5196 13.0801 35.5196 12.4126C35.5196 11.7392 35.3356 11.2416 34.968 10.9201C34.6 10.5986 34.0239 10.4379 33.2388 10.4379H31.9317V14.4616ZM38.4214 12.3108C38.4214 13.7696 37.9657 14.8852 37.0537 15.6575C36.1423 16.4304 34.8459 16.8164 33.1649 16.8164H31.9317V21.6375H29.0577V8.0832H33.3872C35.0315 8.0832 36.2814 8.43708 37.1375 9.14485C37.9936 9.85262 38.4214 10.9081 38.4214 12.3108Z" fill="#F7FAFC"></path></svg></a></div><div class="group-right"><div class="desktop-menu-container"><ul class="MenuList__MenuListContainer-sc-1kinduu-0 ZNNVq"><li><div class="ProductLinks__ProductLinksContainer-sc-1whpvk-0 chCDET"><button class="ProductLinks__ToggleBtn-sc-1whpvk-1 ljgoDM"><span>Products</span><svg xmlns="http://www.w3.org/2000/svg" width="16" height="16" viewBox="0 0 24 24" fill="none" stroke="#EDF2F7" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><polyline points="6 9 12 15 18 9"></polyline></svg></button></div></li><li><a href="https://www.prisma.io/docs/getting-started/quickstart">Quickstart</a></li><li><a href="https://www.prisma.io/docs/">Docs</a></li><li><a href="https://www.prisma.io/docs/about/prisma/faq">FAQ</a></li><li><a href="https://www.prisma.io/community">Community</a></li><li><a href="https://www.prisma.io/blog/">Blog</a></li><li><a href="https://github.com/prisma/prisma" class="github"><svg width="24" height="24" viewBox="0 0 18 18"><path d="M16.7926 4.70258C15.9878 3.32365 14.8961 2.23195 13.5173 1.42724C12.1383 0.622478 10.6328 0.220201 8.99986 0.220201C7.36707 0.220201 5.8611 0.622601 4.48238 1.42724C3.10345 2.23191 2.01183 3.32365 1.20703 4.70258C0.402359 6.08147 0 7.58723 0 9.21981C0 11.1809 0.57216 12.9444 1.71677 14.5107C2.86125 16.0771 4.33975 17.161 6.15215 17.7625C6.36312 17.8017 6.51929 17.7741 6.62084 17.6806C6.72242 17.5869 6.77315 17.4696 6.77315 17.3292C6.77315 17.3057 6.77114 17.0949 6.76724 16.6964C6.76322 16.2979 6.76133 15.9502 6.76133 15.6536L6.49179 15.7002C6.31994 15.7317 6.10314 15.7451 5.8414 15.7413C5.57979 15.7376 5.3082 15.7102 5.027 15.6592C4.74568 15.6087 4.48402 15.4915 4.24182 15.3079C3.99974 15.1243 3.82789 14.884 3.7263 14.5874L3.60912 14.3177C3.53101 14.1382 3.40804 13.9387 3.24005 13.7201C3.07205 13.5013 2.90217 13.353 2.73032 13.2749L2.64827 13.2161C2.5936 13.1771 2.54287 13.13 2.49595 13.0754C2.44908 13.0208 2.41399 12.9661 2.39055 12.9113C2.36707 12.8566 2.38653 12.8116 2.44912 12.7764C2.51171 12.7411 2.62483 12.724 2.78897 12.724L3.02325 12.759C3.17951 12.7903 3.37279 12.8838 3.60333 13.0402C3.83376 13.1964 4.02318 13.3995 4.17163 13.6494C4.35141 13.9698 4.568 14.2139 4.82202 14.3819C5.07584 14.5499 5.33176 14.6337 5.58951 14.6337C5.84727 14.6337 6.0699 14.6142 6.25747 14.5753C6.44484 14.5363 6.62063 14.4775 6.78477 14.3995C6.85508 13.8758 7.04651 13.4735 7.3589 13.1923C6.91365 13.1455 6.51334 13.0751 6.15777 12.9814C5.80241 12.8875 5.43519 12.7353 5.05635 12.5241C4.6773 12.3133 4.36286 12.0515 4.11294 11.7391C3.86298 11.4266 3.65784 11.0163 3.49781 10.5086C3.33769 10.0008 3.25761 9.4149 3.25761 8.75088C3.25761 7.80542 3.56627 7.00087 4.18345 6.33677C3.89434 5.62596 3.92163 4.82912 4.26542 3.94634C4.49199 3.87595 4.82798 3.92877 5.27323 4.10448C5.71856 4.28028 6.04461 4.43087 6.25172 4.55573C6.45883 4.68054 6.62478 4.78631 6.7498 4.8721C7.47649 4.66905 8.22641 4.56751 8.99977 4.56751C9.77313 4.56751 10.5232 4.66905 11.25 4.8721L11.6952 4.59098C11.9998 4.40341 12.3593 4.23152 12.7732 4.07526C13.1872 3.91909 13.5038 3.87607 13.7227 3.94646C14.0741 4.82929 14.1054 5.62608 13.8162 6.33689C14.4334 7.00099 14.7421 7.80575 14.7421 8.751C14.7421 9.41502 14.6618 10.0027 14.5019 10.5145C14.3418 11.0264 14.1349 11.4363 13.8811 11.745C13.627 12.0537 13.3105 12.3135 12.9317 12.5243C12.5528 12.7352 12.1854 12.8875 11.8301 12.9813C11.4745 13.0752 11.0742 13.1457 10.629 13.1925C11.0351 13.544 11.2382 14.0987 11.2382 14.8564V17.3288C11.2382 17.4693 11.287 17.5866 11.3848 17.6803C11.4824 17.7738 11.6366 17.8013 11.8476 17.7621C13.6602 17.1607 15.1387 16.0768 16.2832 14.5104C17.4275 12.9441 17.9999 11.1806 17.9999 9.21948C17.9995 7.5871 17.5969 6.08147 16.7926 4.70258Z" class="md:hover:text-white"></path></svg><span>GitHub</span></a></li></ul></div><div class="mobile-menu-btn"><button class="Navbar__MobileMenuBtn-sc-1kck62g-1 jefKLL"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" fill="none" stroke="#F7FAFC" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><line x1="3" y1="12" x2="21" y2="12"></line><line x1="3" y1="6" x2="21" y2="6"></line><line x1="3" y1="18" x2="21" y2="18"></line></svg></button></div></div></nav></div></div><div class="header__SecondLevelHeader-sc-1w16195-6 iGkkZE"><div style="display:flex" class="header__Container-sc-1w16195-1 bQLcOk"><div class="sc-bdvvtL bEBtCB"></div><div class="input__SearchBoxDiv-sc-1nmahfx-0 feLizT"><form><svg width="16" height="16" viewBox="0 0 16 16" fill="none" xmlns="http://www.w3.org/2000/svg" class="input__SearchIcon-sc-1nmahfx-1 TkthA"><path d="M7 13C10.3137 13 13 10.3137 13 7C13 3.68629 10.3137 1 7 1C3.68629 1 1 3.68629 1 7C1 10.3137 3.68629 13 7 13Z" stroke="#4A5568" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M15 15L12 12" stroke="#4A5568" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg><input type="text" placeholder="Search Documentation..." aria-label="Search Documentation..." value=""/><svg width="18" height="28" viewBox="0 0 18 28" fill="none" xmlns="http://www.w3.org/2000/svg" class="input__SearchSlashIcon-sc-1nmahfx-2 hyRyPK"><path d="M11.2734 8.57812L7.01562 20H5.71875L9.97656 8.57812H11.2734Z" fill="#CBD5E0"></path><rect x="0.5" y="0.5" width="17" height="27" rx="3.5" stroke="#CBD5E0"></rect></svg></form></div><div style="width:100%" class="header__NonMobileMenu-sc-1w16195-7 dBOaPl"><div class="header__SecondLevelNav-sc-1w16195-11 iGOfTy"><div><a class="header__NavLink-sc-1w16195-8 header__DarkNavLink-sc-1w16195-9 jZqhCv drTaKv non-active" href="/docs/getting-started">Getting Started</a><a class="header__NavLink-sc-1w16195-8 header__DarkNavLink-sc-1w16195-9 jZqhCv drTaKv non-active" href="/docs/concepts">Concepts</a><a class="header__NavLink-sc-1w16195-8 header__DarkNavLink-sc-1w16195-9 jZqhCv drTaKv active-item" href="/docs/guides">Guides</a><a class="header__NavLink-sc-1w16195-8 header__DarkNavLink-sc-1w16195-9 jZqhCv drTaKv non-active" href="/docs/reference">Reference</a><a class="header__NavLink-sc-1w16195-8 header__DarkNavLink-sc-1w16195-9 jZqhCv drTaKv non-active" href="/docs/support">Support</a><a class="header__NavLink-sc-1w16195-8 header__DarkNavLink-sc-1w16195-9 jZqhCv drTaKv non-active" href="/docs/about">About</a></div><div><a href="https://v1.prisma.io/docs/1.34" class="header__NavLink-sc-1w16195-8 header__DarkNavLink-sc-1w16195-9 jZqhCv drTaKv link">Prisma 1 Docs<!-- -->   <svg width="16" height="16" viewBox="0 0 16 16" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M12 8.66667V12.6667C12 13.0203 11.8595 13.3594 11.6095 13.6095C11.3594 13.8595 11.0203 14 10.6667 14H3.33333C2.97971 14 2.64057 13.8595 2.39052 13.6095C2.14048 13.3594 2 13.0203 2 12.6667V5.33333C2 4.97971 2.14048 4.64057 2.39052 4.39052C2.64057 4.14048 2.97971 4 3.33333 4H7.33333" stroke="#718096" stroke-width="1.5" stroke-linecap="round" stroke-linejoin="round"></path><path d="M10 2H14V6" stroke="#718096" stroke-width="1.5" stroke-linecap="round" stroke-linejoin="round"></path><path d="M6.66669 9.33333L14 2" stroke="#718096" stroke-width="1.5" stroke-linecap="round" stroke-linejoin="round"></path></svg></a></div></div></div><div class="header__DocsMobileButton-sc-1w16195-3 dwJPWb">Docs<svg width="14" height="8" viewBox="0 0 14 8" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M1 1L7 7L13 1" stroke="#718096" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></div></div></div><div class="layout__Wrapper-sc-bupt9j-0 kDTMNX"><div class="layout__Container-sc-bupt9j-4 dtQphc"><div><section id="sidebar-holder" class="layout__NotMobile-sc-bupt9j-3 bMpSuc"><aside class="sidebar__SidebarContainer-sc-u94sja-0 ekKAbK"><div id="sidebar-container" class="sidebar__Sidebar-sc-u94sja-1 gWIUMo"><ul class="sidebar__List-sc-u94sja-2 fKPVpa"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     "><ul class="treeNode__List-sc-a5dz51-0 dRPWsq"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD  top-level   "><a class="active-item" id="/docs/guides"><span class="">Guides</span></a><ul class="treeNode__List-sc-a5dz51-0 dRPWsq"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     "></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  "><a class="active-item" id="/docs/guides/database"><span class="">Database guides</span></a><ul class="treeNode__List-sc-a5dz51-0 dRPWsq"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="active-item" id="/docs/guides/database/developing-with-prisma-migrate" href="/docs/guides/database/developing-with-prisma-migrate"><span class="collapse-title"><button aria-label="collapse" class="item-collapser "><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button><span class="">Developing with Prisma Migrate</span></span></a><ul class="treeNode__List-sc-a5dz51-0 dRPWsq has-border"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD    last-level more-padding"><a class="non-active" id="/docs/guides/database/developing-with-prisma-migrate/add-prisma-migrate-to-a-project" href="/docs/guides/database/developing-with-prisma-migrate/add-prisma-migrate-to-a-project"><span class="">Adding Prisma Migrate to an existing project</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD    last-level more-padding"><a class="non-active" id="/docs/guides/database/developing-with-prisma-migrate/team-development" href="/docs/guides/database/developing-with-prisma-migrate/team-development"><span class="">Team development with Prisma Migrate</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD    last-level more-padding"><a class="non-active" id="/docs/guides/database/developing-with-prisma-migrate/baselining" href="/docs/guides/database/developing-with-prisma-migrate/baselining"><span class="">Baselining a database</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD    last-level more-padding"><a class="non-active" id="/docs/guides/database/developing-with-prisma-migrate/enable-native-database-functions" href="/docs/guides/database/developing-with-prisma-migrate/enable-native-database-functions"><span class="">Enable extensions for native database functions</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD    last-level more-padding"><a class="non-active" id="/docs/guides/database/developing-with-prisma-migrate/include-unsupported-database-features" href="/docs/guides/database/developing-with-prisma-migrate/include-unsupported-database-features"><span class="">Include unsupported database features</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD    last-level more-padding"><a class="non-active" id="/docs/guides/database/developing-with-prisma-migrate/customizing-migrations" href="/docs/guides/database/developing-with-prisma-migrate/customizing-migrations"><span class="">Customizing migrations</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD    last-level more-padding"><a class="non-active" id="/docs/guides/database/developing-with-prisma-migrate/squashing-migrations" href="/docs/guides/database/developing-with-prisma-migrate/squashing-migrations"><span class="">Squashing migrations</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD    last-level more-padding"><a aria-current="page" class="active-item active-item" id="/docs/guides/database/developing-with-prisma-migrate/generating-down-migrations" href="/docs/guides/database/developing-with-prisma-migrate/generating-down-migrations"><span class="">Generating down migrations</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD    last-level more-padding"><a class="non-active" id="/docs/guides/database/developing-with-prisma-migrate/troubleshooting-development" href="/docs/guides/database/developing-with-prisma-migrate/troubleshooting-development"><span class="">Migration troubleshooting in development</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD    last-level more-padding"></li></ul></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/database/seed-database" href="/docs/guides/database/seed-database"><span class="">Seeding your database</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/database/prototyping-schema-db-push" href="/docs/guides/database/prototyping-schema-db-push"><span class="">Schema prototyping with db push</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/database/patching-production" href="/docs/guides/database/patching-production"><span class="">Patching / hotfixing a database in production</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/database/production-troubleshooting" href="/docs/guides/database/production-troubleshooting"><span class="">Migration troubleshooting in production</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/database/using-prisma-with-planetscale" href="/docs/guides/database/using-prisma-with-planetscale"><span class="">Using Prisma with PlanetScale</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/database/using-prisma-with-mongodb" href="/docs/guides/database/using-prisma-with-mongodb"><span class="">Using Prisma with MongoDB</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/database/advanced-database-tasks" href="/docs/guides/database/advanced-database-tasks"><span class="collapse-title"><button aria-label="collapse" class="item-collapser "><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button><span class="">Advanced database tasks</span></span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  more-padding"></li></ul></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  "><a class="non-active" id="/docs/guides/performance-and-optimization"><span class="">Performance and optimization</span></a><ul class="treeNode__List-sc-a5dz51-0 dRPWsq"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/performance-and-optimization/query-optimization-performance" href="/docs/guides/performance-and-optimization/query-optimization-performance"><span class="">Query optimization</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/performance-and-optimization/prisma-client-transactions-guide" href="/docs/guides/performance-and-optimization/prisma-client-transactions-guide"><span class="">Transactions</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/performance-and-optimization/connection-management" href="/docs/guides/performance-and-optimization/connection-management"><span class="collapse-title"><button aria-label="collapse" class="item-collapser "><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button><span class="">Connection management</span></span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  more-padding"></li></ul></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  "><a class="non-active" id="/docs/guides/development-environment"><span class="">Development environment</span></a><ul class="treeNode__List-sc-a5dz51-0 dRPWsq"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/development-environment/environment-variables" href="/docs/guides/development-environment/environment-variables"><span class="collapse-title"><button aria-label="collapse" class="item-collapser "><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button><span class="">Environment variables</span></span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/development-environment/editor-setup" href="/docs/guides/development-environment/editor-setup"><span class="">Editor setup</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  more-padding"></li></ul></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  "><a class="non-active" id="/docs/guides/testing"><span class="">Testing</span></a><ul class="treeNode__List-sc-a5dz51-0 dRPWsq"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/testing/unit-testing" href="/docs/guides/testing/unit-testing"><span class="">Unit testing</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/testing/integration-testing" href="/docs/guides/testing/integration-testing"><span class="">Integration testing</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  more-padding"></li></ul></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  "><a class="non-active" id="/docs/guides/deployment"><span class="">Deployment</span></a><ul class="treeNode__List-sc-a5dz51-0 dRPWsq"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/deployment/deployment" href="/docs/guides/deployment/deployment"><span class="">Deployment overview</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/deployment/deployment-guides" href="/docs/guides/deployment/deployment-guides"><span class="collapse-title"><button aria-label="collapse" class="item-collapser "><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button><span class="">Deployment guides</span></span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/deployment/deploy-database-changes-with-prisma-migrate" href="/docs/guides/deployment/deploy-database-changes-with-prisma-migrate"><span class="">Deploying database changes with Prisma Migrate</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  more-padding"></li></ul></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  "><a class="non-active" id="/docs/guides/upgrade-guides"><span class="">Upgrading</span></a><ul class="treeNode__List-sc-a5dz51-0 dRPWsq"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/upgrade-guides/upgrading-versions" href="/docs/guides/upgrade-guides/upgrading-versions"><span class="collapse-title"><button aria-label="collapse" class="item-collapser "><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button><span class="">Upgrading versions</span></span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/upgrade-guides/upgrading-to-use-preview-features" href="/docs/guides/upgrade-guides/upgrading-to-use-preview-features"><span class="">Upgrading to use Preview features</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/upgrade-guides/upgrade-from-prisma-1" href="/docs/guides/upgrade-guides/upgrade-from-prisma-1"><span class="collapse-title"><button aria-label="collapse" class="item-collapser "><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button><span class="">Upgrade from Prisma 1</span></span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/upgrade-guides/upgrade-from-graphcool" href="/docs/guides/upgrade-guides/upgrade-from-graphcool"><span class="">Upgrade from Graphcool</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  more-padding"></li></ul></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  "><a class="non-active" id="/docs/guides/migrate-to-prisma"><span class="">Migrate to Prisma</span></a><ul class="treeNode__List-sc-a5dz51-0 dRPWsq"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/migrate-to-prisma/migrate-from-typeorm" href="/docs/guides/migrate-to-prisma/migrate-from-typeorm"><span class="">Migrate from TypeORM</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/migrate-to-prisma/migrate-from-sequelize" href="/docs/guides/migrate-to-prisma/migrate-from-sequelize"><span class="">Migrate from Sequelize</span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  more-padding"></li></ul></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  "><a class="non-active" id="/docs/guides/general-guides"><span class="">General guides</span></a><ul class="treeNode__List-sc-a5dz51-0 dRPWsq"><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD     more-padding"><a class="non-active" id="/docs/guides/general-guides/database-workflows" href="/docs/guides/general-guides/database-workflows"><span class="collapse-title"><button aria-label="collapse" class="item-collapser "><svg width="5" height="8" viewBox="0 0 5 8" fill="none" xmlns="http://www.w3.org/2000/svg" class="right close"><path d="M0 0.724246C0 0.111374 0.681914 -0.223425 1.13107 0.168926L4.66916 3.25957C5.11028 3.6449 5.11028 4.3551 4.66916 4.74043L1.13107 7.83107C0.681913 8.22342 0 7.88863 0 7.27575V0.724246Z" fill="#A0AEC0"></path></svg><svg width="8" height="6" viewBox="0 0 8 6" fill="none" xmlns="http://www.w3.org/2000/svg" class="down close"><path d="M7.27575 0.5C7.88863 0.5 8.22342 1.18191 7.83107 1.63107L4.74043 5.16916C4.3551 5.61028 3.6449 5.61028 3.25957 5.16916L0.168926 1.63107C-0.223425 1.18191 0.111375 0.5 0.724247 0.5L7.27575 0.5Z" fill="#A0AEC0"></path></svg></button><span class="">Database workflows</span></span></a></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD   static-link  more-padding"></li></ul></li><li class="treeNode__ListItem-sc-a5dz51-1 jWVQtD  top-level   "></li></ul></li></ul></li></ul></div></aside></section></div><article class="layout__Content-sc-bupt9j-1 ihDvDM"><div class="layout__MaxWidth-sc-bupt9j-2 lkLzBP"><section class="top-section"><div class="topSection__TopSectionWrapper-sc-d3j04s-0 bdhoQh"><div class="topSection__Header-sc-d3j04s-1 gaxqaa"><div class="title"><div class="parentTitleComp__BreadcrumbTitle-sc-f3mbxz-0 fMgRcK"><span><a href="/docs/guides"><span class="">Guides</span></a> / </span><span><a href="/docs/guides/database"><span class="">Database guides</span></a> / </span><span><a href="/docs/guides/database/developing-with-prisma-migrate"><span class="">Developing with Prisma Migrate</span></a></span></div><h1 class="topSection__MainTitle-sc-d3j04s-2 fRZvcB">Generating down migrations</h1></div><div class="tech-switch-block"></div></div></div></section><section><p class="paragraph">This guide describes how to generate a down migration SQL file that reverses a given <a href="/docs/concepts/components/prisma-migrate#migration-history">migration file</a>.</p></section><section><h2 id="about-down-migrations" style="position:relative"><a href="#about-down-migrations" aria-label="about down migrations permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>About down migrations</h2><p class="paragraph">When generating a migration SQL file, you may wish to also create a &quot;down migration&quot; SQL file that reverses the schema changes in the corresponding &quot;up migration&quot; file.</p><p class="paragraph">This guide explains how to use Prisma Migrate&#x27;s <a href="/docs/reference/api-reference/command-reference#migrate-diff"><code class="inline-code">migrate diff</code> command</a> to create a down migration, and how to apply it to your production database with the <a href="/docs/reference/api-reference/command-reference#db-execute"><code class="inline-code">db execute</code></a> command.</p><span type="info" class="admonition__AdmonitionWrapper-sc-66wrbe-2 cQEzMN"><p class="paragraph">This guide applies to generating SQL down migrations for relational databases only. It does not apply to MongoDB.</p></span><span type="info" class="admonition__AdmonitionWrapper-sc-66wrbe-2 cQEzMN"><p class="paragraph">The <code class="inline-code">migrate diff</code> and <code class="inline-code">db execute</code> commands are available in Preview in versions <code class="inline-code">3.9.0</code> and later, and are generally available in versions <code class="inline-code">3.13.0</code> and later.</p></span></section><section><h2 id="considerations-when-generating-down-migrations" style="position:relative"><a href="#considerations-when-generating-down-migrations" aria-label="considerations when generating down migrations permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Considerations when generating down migrations</h2><p class="paragraph">When generating a down migration file, there are some considerations to be aware of:</p><ul class="list"><li>The down migration will revert your database schema, but other changes to data and application code that are carried out as part of the up migration will not be reverted. For example, if you have a script that changes data during the migration, this data will not be changed back when you run the down migration.</li><li>You will not be able to use <code class="inline-code">migrate diff</code> to revert manually changed or added SQL in your migration files. If you have any custom additions, such as a view or trigger, you will need to:<ul class="list"><li>Create the down migration following <a href="#how-to-generate-and-run-down-migrations">the instructions below</a></li><li>Create the up migration using <a href="/docs/reference/api-reference/command-reference#options-6"><code class="inline-code">migrate dev --create-only</code></a>, so that it can be edited before it is applied to the database</li><li>Manually add your custom SQL to the up migration (e.g. adding a view)</li><li>Manually add the inverted custom SQL to the down migration (e.g. dropping the view)</li></ul></li></ul></section><section><h2 id="how-to-generate-and-run-down-migrations" style="position:relative"><a href="#how-to-generate-and-run-down-migrations" aria-label="how to generate and run down migrations permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>How to generate and run down migrations</h2><p class="paragraph">This section describes how to generate a down migration SQL file along with the corresponding up migration, and then run it on production.</p><p class="paragraph">As an example, take the following Prisma schema with a <code class="inline-code">User</code> and <code class="inline-code">Post</code> model as a starting point:</p><pre><div class="code__CodeWrapper-sc-k1a3m7-0 eqfpcQ codeWrapperDiv"><div class="file"><span class="fileWithIcon__FileNameWrapper-sc-19df6uw-0 Qyrei"><svg width="12" height="15" viewBox="0 0 12 15" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M6.625 1.99609H2.25C1.91848 1.99609 1.60054 2.12252 1.36612 2.34757C1.1317 2.57261 1 2.87783 1 3.19609V12.7961C1 13.1144 1.1317 13.4196 1.36612 13.6446C1.60054 13.8697 1.91848 13.9961 2.25 13.9961H9.75C10.0815 13.9961 10.3995 13.8697 10.6339 13.6446C10.8683 13.4196 11 13.1144 11 12.7961V6.19609L6.625 1.99609Z" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M5 1.99609V7.99609H11" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg>schema.prisma</span></div><div class="gatsby-highlight pre-highlight"><pre class="code__Pre-sc-k1a3m7-2 bYFTXA prism-code language-prisma " style="color:#393A34;background-color:#f6f8fa"><div class="code__AbsoluteCopyButton-sc-k1a3m7-1 zFDDZ copy-button"><div class="copy__CopyComponent-sc-1hcrz7p-0 iRxhpH"><svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"><rect x="0.5" width="24" height="24" rx="4" fill="#EDF2F7"></rect><path d="M15.5001 6.40002H17.0002C17.398 6.40002 17.7795 6.54752 18.0608 6.81007C18.3422 7.07263 18.5002 7.42872 18.5002 7.80002V17.6C18.5002 17.9713 18.3422 18.3274 18.0608 18.59C17.7795 18.8525 17.398 19 17.0002 19H8.00002C7.60219 19 7.22066 18.8525 6.93935 18.59C6.65804 18.3274 6.5 17.9713 6.5 17.6V7.80002C6.5 7.42872 6.65804 7.07263 6.93935 6.81007C7.22066 6.54752 7.60219 6.40002 8.00002 6.40002H9.50005" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M14.75 5H10.25C9.83579 5 9.5 5.33579 9.5 5.75V7.25C9.5 7.66421 9.83579 8 10.25 8H14.75C15.1642 8 15.5 7.66421 15.5 7.25V5.75C15.5 5.33579 15.1642 5 14.75 5Z" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></div></div><code><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">1</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token keyword" style="color:#00009f">model</span><span class="token plain"> Post </span><span class="token punctuation" style="color:#393A34">{</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">2</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  id</span><span class="token type-class-name">       Int</span><span class="token plain">     </span><span class="token annotation punctuation" style="color:#393A34">@id</span><span class="token plain"> </span><span class="token annotation punctuation" style="color:#393A34">@default</span><span class="token punctuation" style="color:#393A34">(</span><span class="token function" style="color:#d73a49">autoincrement</span><span class="token punctuation" style="color:#393A34">(</span><span class="token punctuation" style="color:#393A34">)</span><span class="token punctuation" style="color:#393A34">)</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">3</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  title</span><span class="token type-class-name">    String</span><span class="token plain">  </span><span class="token annotation punctuation" style="color:#393A34">@db</span><span class="token punctuation" style="color:#393A34">.</span><span class="token function" style="color:#d73a49">VarChar</span><span class="token punctuation" style="color:#393A34">(</span><span class="token number" style="color:#36acaa">255</span><span class="token punctuation" style="color:#393A34">)</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">4</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  content</span><span class="token type-class-name">  String</span><span class="token operator" style="color:#393A34">?</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">5</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  author</span><span class="token type-class-name">   User</span><span class="token plain">    </span><span class="token annotation punctuation" style="color:#393A34">@relation</span><span class="token punctuation" style="color:#393A34">(</span><span class="token type-args">fields:</span><span class="token plain"> </span><span class="token punctuation" style="color:#393A34">[</span><span class="token plain">authorId</span><span class="token punctuation" style="color:#393A34">]</span><span class="token punctuation" style="color:#393A34">,</span><span class="token plain"> </span><span class="token type-args">references:</span><span class="token plain"> </span><span class="token punctuation" style="color:#393A34">[</span><span class="token plain">id</span><span class="token punctuation" style="color:#393A34">]</span><span class="token punctuation" style="color:#393A34">)</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">6</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  authorId</span><span class="token type-class-name"> Int</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">7</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain"></span><span class="token punctuation" style="color:#393A34">}</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">8</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain" style="display:inline-block">
</span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">9</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain"></span><span class="token keyword" style="color:#00009f">model</span><span class="token plain"> User </span><span class="token punctuation" style="color:#393A34">{</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">10</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  id</span><span class="token type-class-name">    Int</span><span class="token plain">     </span><span class="token annotation punctuation" style="color:#393A34">@id</span><span class="token plain"> </span><span class="token annotation punctuation" style="color:#393A34">@default</span><span class="token punctuation" style="color:#393A34">(</span><span class="token function" style="color:#d73a49">autoincrement</span><span class="token punctuation" style="color:#393A34">(</span><span class="token punctuation" style="color:#393A34">)</span><span class="token punctuation" style="color:#393A34">)</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">11</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  name</span><span class="token type-class-name">  String</span><span class="token operator" style="color:#393A34">?</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">12</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  posts</span><span class="token type-class-name"> Post</span><span class="token punctuation" style="color:#393A34">[</span><span class="token punctuation" style="color:#393A34">]</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">13</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain"></span><span class="token punctuation" style="color:#393A34">}</span><span class="token plain"></span></span></div></code></pre></div></div></pre><p class="paragraph">You will need to create the down migration first, before creating the corresponding up migration.</p><section><h3 id="generating-the-migrations" style="position:relative"><a href="#generating-the-migrations" aria-label="generating the migrations permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Generating the migrations</h3><ol class="o-list"><li><p class="paragraph">Edit your Prisma schema to make the changes you require for your up migration. In this example, you will add a new <code class="inline-code">Profile</code> model:</p><pre><div class="code__CodeWrapper-sc-k1a3m7-0 eqfpcQ codeWrapperDiv"><div class="file"><span class="fileWithIcon__FileNameWrapper-sc-19df6uw-0 Qyrei"><svg width="12" height="15" viewBox="0 0 12 15" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M6.625 1.99609H2.25C1.91848 1.99609 1.60054 2.12252 1.36612 2.34757C1.1317 2.57261 1 2.87783 1 3.19609V12.7961C1 13.1144 1.1317 13.4196 1.36612 13.6446C1.60054 13.8697 1.91848 13.9961 2.25 13.9961H9.75C10.0815 13.9961 10.3995 13.8697 10.6339 13.6446C10.8683 13.4196 11 13.1144 11 12.7961V6.19609L6.625 1.99609Z" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M5 1.99609V7.99609H11" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg>schema.prisma</span></div><div class="gatsby-highlight pre-highlight"><pre class="code__Pre-sc-k1a3m7-2 bYFTXA prism-code language-prisma " style="color:#393A34;background-color:#f6f8fa"><div class="code__AbsoluteCopyButton-sc-k1a3m7-1 zFDDZ copy-button"><div class="copy__CopyComponent-sc-1hcrz7p-0 iRxhpH"><svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"><rect x="0.5" width="24" height="24" rx="4" fill="#EDF2F7"></rect><path d="M15.5001 6.40002H17.0002C17.398 6.40002 17.7795 6.54752 18.0608 6.81007C18.3422 7.07263 18.5002 7.42872 18.5002 7.80002V17.6C18.5002 17.9713 18.3422 18.3274 18.0608 18.59C17.7795 18.8525 17.398 19 17.0002 19H8.00002C7.60219 19 7.22066 18.8525 6.93935 18.59C6.65804 18.3274 6.5 17.9713 6.5 17.6V7.80002C6.5 7.42872 6.65804 7.07263 6.93935 6.81007C7.22066 6.54752 7.60219 6.40002 8.00002 6.40002H9.50005" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M14.75 5H10.25C9.83579 5 9.5 5.33579 9.5 5.75V7.25C9.5 7.66421 9.83579 8 10.25 8H14.75C15.1642 8 15.5 7.66421 15.5 7.25V5.75C15.5 5.33579 15.1642 5 14.75 5Z" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></div></div><code><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">1</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token keyword" style="color:#00009f">model</span><span class="token plain"> Post </span><span class="token punctuation" style="color:#393A34">{</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">2</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  id</span><span class="token type-class-name">       Int</span><span class="token plain">     </span><span class="token annotation punctuation" style="color:#393A34">@id</span><span class="token plain"> </span><span class="token annotation punctuation" style="color:#393A34">@default</span><span class="token punctuation" style="color:#393A34">(</span><span class="token function" style="color:#d73a49">autoincrement</span><span class="token punctuation" style="color:#393A34">(</span><span class="token punctuation" style="color:#393A34">)</span><span class="token punctuation" style="color:#393A34">)</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">3</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  title</span><span class="token type-class-name">    String</span><span class="token plain">  </span><span class="token annotation punctuation" style="color:#393A34">@db</span><span class="token punctuation" style="color:#393A34">.</span><span class="token function" style="color:#d73a49">VarChar</span><span class="token punctuation" style="color:#393A34">(</span><span class="token number" style="color:#36acaa">255</span><span class="token punctuation" style="color:#393A34">)</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">4</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  content</span><span class="token type-class-name">  String</span><span class="token operator" style="color:#393A34">?</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">5</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  author</span><span class="token type-class-name">   User</span><span class="token plain">    </span><span class="token annotation punctuation" style="color:#393A34">@relation</span><span class="token punctuation" style="color:#393A34">(</span><span class="token type-args">fields:</span><span class="token plain"> </span><span class="token punctuation" style="color:#393A34">[</span><span class="token plain">authorId</span><span class="token punctuation" style="color:#393A34">]</span><span class="token punctuation" style="color:#393A34">,</span><span class="token plain"> </span><span class="token type-args">references:</span><span class="token plain"> </span><span class="token punctuation" style="color:#393A34">[</span><span class="token plain">id</span><span class="token punctuation" style="color:#393A34">]</span><span class="token punctuation" style="color:#393A34">)</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">6</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  authorId</span><span class="token type-class-name"> Int</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">7</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain"></span><span class="token punctuation" style="color:#393A34">}</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:var(--code-added-bg-color);symb-color:var(--code-added-color)"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no" style="color:var(--code-added-color)">+</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain" style="display:inline-block">
</span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:var(--code-added-bg-color);symb-color:var(--code-added-color)"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no" style="color:var(--code-added-color)">+</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain"></span><span class="token keyword" style="color:#00009f">model</span><span class="token plain"> Profile </span><span class="token punctuation" style="color:#393A34">{</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:var(--code-added-bg-color);symb-color:var(--code-added-color)"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no" style="color:var(--code-added-color)">+</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  id</span><span class="token type-class-name">     Int</span><span class="token plain">     </span><span class="token annotation punctuation" style="color:#393A34">@id</span><span class="token plain"> </span><span class="token annotation punctuation" style="color:#393A34">@default</span><span class="token punctuation" style="color:#393A34">(</span><span class="token function" style="color:#d73a49">autoincrement</span><span class="token punctuation" style="color:#393A34">(</span><span class="token punctuation" style="color:#393A34">)</span><span class="token punctuation" style="color:#393A34">)</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:var(--code-added-bg-color);symb-color:var(--code-added-color)"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no" style="color:var(--code-added-color)">+</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  bio</span><span class="token type-class-name">    String</span><span class="token operator" style="color:#393A34">?</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:var(--code-added-bg-color);symb-color:var(--code-added-color)"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no" style="color:var(--code-added-color)">+</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  user</span><span class="token type-class-name">   User</span><span class="token plain">    </span><span class="token annotation punctuation" style="color:#393A34">@relation</span><span class="token punctuation" style="color:#393A34">(</span><span class="token type-args">fields:</span><span class="token plain"> </span><span class="token punctuation" style="color:#393A34">[</span><span class="token plain">userId</span><span class="token punctuation" style="color:#393A34">]</span><span class="token punctuation" style="color:#393A34">,</span><span class="token plain"> </span><span class="token type-args">references:</span><span class="token plain"> </span><span class="token punctuation" style="color:#393A34">[</span><span class="token plain">id</span><span class="token punctuation" style="color:#393A34">]</span><span class="token punctuation" style="color:#393A34">)</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:var(--code-added-bg-color);symb-color:var(--code-added-color)"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no" style="color:var(--code-added-color)">+</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  userId</span><span class="token type-class-name"> Int</span><span class="token plain">     </span><span class="token annotation punctuation" style="color:#393A34">@unique</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:var(--code-added-bg-color);symb-color:var(--code-added-color)"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no" style="color:var(--code-added-color)">+</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain"></span><span class="token punctuation" style="color:#393A34">}</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">15</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain" style="display:inline-block">
</span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">16</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain"></span><span class="token keyword" style="color:#00009f">model</span><span class="token plain"> User </span><span class="token punctuation" style="color:#393A34">{</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">17</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  id</span><span class="token type-class-name">      Int</span><span class="token plain">      </span><span class="token annotation punctuation" style="color:#393A34">@id</span><span class="token plain"> </span><span class="token annotation punctuation" style="color:#393A34">@default</span><span class="token punctuation" style="color:#393A34">(</span><span class="token function" style="color:#d73a49">autoincrement</span><span class="token punctuation" style="color:#393A34">(</span><span class="token punctuation" style="color:#393A34">)</span><span class="token punctuation" style="color:#393A34">)</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">18</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  name</span><span class="token type-class-name">    String</span><span class="token operator" style="color:#393A34">?</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">19</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  posts</span><span class="token type-class-name">   Post</span><span class="token punctuation" style="color:#393A34">[</span><span class="token punctuation" style="color:#393A34">]</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:var(--code-added-bg-color);symb-color:var(--code-added-color)"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no" style="color:var(--code-added-color)">+</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain">  profile</span><span class="token type-class-name"> Profile</span><span class="token operator" style="color:#393A34">?</span><span class="token plain"></span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">21</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  "><span class="token plain"></span><span class="token punctuation" style="color:#393A34">}</span><span class="token plain"></span></span></div></code></pre></div></div></pre></li><li><p class="paragraph">Generate the SQL file for the down migration. To do this, you will use <code class="inline-code">migrate diff</code> to make a comparison:</p><ul class="list"><li>from the newly edited schema</li><li>to the state of the schema after the last migration</li></ul><p class="paragraph">and output this to a SQL script, <code class="inline-code">down.sql</code>.</p><p class="paragraph">There are two potential options for specifying the &#x27;to&#x27; state:</p><ul class="list"><li><p class="paragraph">Using <code class="inline-code">--to-migrations</code>: this makes a comparison to the state of the migrations given in the migrations directory. This is the preferred option, as it is more robust, but it requires a <a href="/docs/concepts/components/prisma-migrate/shadow-database">shadow database</a>. To use this option, run:</p><pre><div class="code__CodeWrapper-sc-k1a3m7-0 eqfpcQ codeWrapperDiv"><div class="gatsby-highlight pre-highlight"><pre class="code__Pre-sc-k1a3m7-2 bYFTXA prism-code language-terminal is-terminal" style="color:#393A34;background-color:#f6f8fa"><div class="code__AbsoluteCopyButton-sc-k1a3m7-1 zFDDZ copy-button"><div class="copy__CopyComponent-sc-1hcrz7p-0 iRxhpH"><svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"><rect x="0.5" width="24" height="24" rx="4" fill="#EDF2F7"></rect><path d="M15.5001 6.40002H17.0002C17.398 6.40002 17.7795 6.54752 18.0608 6.81007C18.3422 7.07263 18.5002 7.42872 18.5002 7.80002V17.6C18.5002 17.9713 18.3422 18.3274 18.0608 18.59C17.7795 18.8525 17.398 19 17.0002 19H8.00002C7.60219 19 7.22066 18.8525 6.93935 18.59C6.65804 18.3274 6.5 17.9713 6.5 17.6V7.80002C6.5 7.42872 6.65804 7.07263 6.93935 6.81007C7.22066 6.54752 7.60219 6.40002 8.00002 6.40002H9.50005" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M14.75 5H10.25C9.83579 5 9.5 5.33579 9.5 5.75V7.25C9.5 7.66421 9.83579 8 10.25 8H14.75C15.1642 8 15.5 7.66421 15.5 7.25V5.75C15.5 5.33579 15.1642 5 14.75 5Z" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></div></div><code><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain">npx prisma migrate diff \</span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain"> --from-schema-datamodel prisma/schema.prisma \</span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain"> --to-migrations prisma/migrations --shadow-database-url $SHADOW_DATABASE_URL \</span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain"> --script &gt; down.sql</span></span></div></code></pre></div></div></pre></li><li><p class="paragraph">Using <code class="inline-code">--to-schema-datasource</code>: this makes a comparison to the state of the database. This does not require a shadow database, but it does rely on the database having an up-to-date schema. To use this option, run:</p><pre><div class="code__CodeWrapper-sc-k1a3m7-0 eqfpcQ codeWrapperDiv"><div class="gatsby-highlight pre-highlight"><pre class="code__Pre-sc-k1a3m7-2 bYFTXA prism-code language-terminal is-terminal" style="color:#393A34;background-color:#f6f8fa"><div class="code__AbsoluteCopyButton-sc-k1a3m7-1 zFDDZ copy-button"><div class="copy__CopyComponent-sc-1hcrz7p-0 iRxhpH"><svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"><rect x="0.5" width="24" height="24" rx="4" fill="#EDF2F7"></rect><path d="M15.5001 6.40002H17.0002C17.398 6.40002 17.7795 6.54752 18.0608 6.81007C18.3422 7.07263 18.5002 7.42872 18.5002 7.80002V17.6C18.5002 17.9713 18.3422 18.3274 18.0608 18.59C17.7795 18.8525 17.398 19 17.0002 19H8.00002C7.60219 19 7.22066 18.8525 6.93935 18.59C6.65804 18.3274 6.5 17.9713 6.5 17.6V7.80002C6.5 7.42872 6.65804 7.07263 6.93935 6.81007C7.22066 6.54752 7.60219 6.40002 8.00002 6.40002H9.50005" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M14.75 5H10.25C9.83579 5 9.5 5.33579 9.5 5.75V7.25C9.5 7.66421 9.83579 8 10.25 8H14.75C15.1642 8 15.5 7.66421 15.5 7.25V5.75C15.5 5.33579 15.1642 5 14.75 5Z" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></div></div><code><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain">npx prisma migrate diff \</span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain"> --from-schema-datamodel prisma/schema.prisma \</span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain"> --to-schema-datasource prisma/schema.prisma \</span></span></div><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain"> --script &gt; down.sql</span></span></div></code></pre></div></div></pre></li></ul></li><li><p class="paragraph">Generate and apply the up migration with a name of <code class="inline-code">add_profile</code>:</p><pre><div class="code__CodeWrapper-sc-k1a3m7-0 eqfpcQ codeWrapperDiv"><div class="gatsby-highlight pre-highlight"><pre class="code__Pre-sc-k1a3m7-2 bYFTXA prism-code language-terminal is-terminal" style="color:#393A34;background-color:#f6f8fa"><div class="code__AbsoluteCopyButton-sc-k1a3m7-1 zFDDZ copy-button"><div class="copy__CopyComponent-sc-1hcrz7p-0 iRxhpH"><svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"><rect x="0.5" width="24" height="24" rx="4" fill="#EDF2F7"></rect><path d="M15.5001 6.40002H17.0002C17.398 6.40002 17.7795 6.54752 18.0608 6.81007C18.3422 7.07263 18.5002 7.42872 18.5002 7.80002V17.6C18.5002 17.9713 18.3422 18.3274 18.0608 18.59C17.7795 18.8525 17.398 19 17.0002 19H8.00002C7.60219 19 7.22066 18.8525 6.93935 18.59C6.65804 18.3274 6.5 17.9713 6.5 17.6V7.80002C6.5 7.42872 6.65804 7.07263 6.93935 6.81007C7.22066 6.54752 7.60219 6.40002 8.00002 6.40002H9.50005" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M14.75 5H10.25C9.83579 5 9.5 5.33579 9.5 5.75V7.25C9.5 7.66421 9.83579 8 10.25 8H14.75C15.1642 8 15.5 7.66421 15.5 7.25V5.75C15.5 5.33579 15.1642 5 14.75 5Z" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></div></div><code><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain">npx prisma migrate dev --name add_profile</span></span></div></code></pre></div></div></pre><p class="paragraph">This will create a new <code class="inline-code">&lt;timestamp&gt;_add_profile</code> directory inside the <code class="inline-code">prisma/migrations</code> directory, with your new <code class="inline-code">migration.sql</code> up migration file inside.</p></li><li><p class="paragraph">Copy your <code class="inline-code">down.sql</code> file into the new directory along with the up migration file.</p></li></ol></section><section><h3 id="applying-the-down-migration" style="position:relative"><a href="#applying-the-down-migration" aria-label="applying the down migration permalink" class="title-link before"><svg width="17" height="18" viewBox="0 0 17 18" fill="none" xmlns="http://www.w3.org/2000/svg">
      <path d="M1.5 6.33337H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M1.5 11.6666H15.5" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M6.75 1L5 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      <path d="M12 1L10.25 17" stroke="#CBD5E0" stroke-width="2" strokeLineCap="round" strokeLineJoin="round"></path>
      </svg></a>Applying the down migration</h3><p class="paragraph">To apply the down migration on your production database:</p><ol class="o-list"><li><p class="paragraph">Use <code class="inline-code">db execute</code> to run your <code class="inline-code">down.sql</code> file on the database server:</p><pre><div class="code__CodeWrapper-sc-k1a3m7-0 eqfpcQ codeWrapperDiv"><div class="gatsby-highlight pre-highlight"><pre class="code__Pre-sc-k1a3m7-2 bYFTXA prism-code language-terminal is-terminal" style="color:#393A34;background-color:#f6f8fa"><div class="code__AbsoluteCopyButton-sc-k1a3m7-1 zFDDZ copy-button"><div class="copy__CopyComponent-sc-1hcrz7p-0 iRxhpH"><svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"><rect x="0.5" width="24" height="24" rx="4" fill="#EDF2F7"></rect><path d="M15.5001 6.40002H17.0002C17.398 6.40002 17.7795 6.54752 18.0608 6.81007C18.3422 7.07263 18.5002 7.42872 18.5002 7.80002V17.6C18.5002 17.9713 18.3422 18.3274 18.0608 18.59C17.7795 18.8525 17.398 19 17.0002 19H8.00002C7.60219 19 7.22066 18.8525 6.93935 18.59C6.65804 18.3274 6.5 17.9713 6.5 17.6V7.80002C6.5 7.42872 6.65804 7.07263 6.93935 6.81007C7.22066 6.54752 7.60219 6.40002 8.00002 6.40002H9.50005" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M14.75 5H10.25C9.83579 5 9.5 5.33579 9.5 5.75V7.25C9.5 7.66421 9.83579 8 10.25 8H14.75C15.1642 8 15.5 7.66421 15.5 7.25V5.75C15.5 5.33579 15.1642 5 14.75 5Z" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></div></div><code><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain">npx prisma db execute --file ./down.sql --schema prisma/schema.prisma</span></span></div></code></pre></div></div></pre></li><li><p class="paragraph">Use <code class="inline-code">migrate resolve</code> to record that you rolled back the up migration named <code class="inline-code">add_profile</code>:</p><pre><div class="code__CodeWrapper-sc-k1a3m7-0 eqfpcQ codeWrapperDiv"><div class="gatsby-highlight pre-highlight"><pre class="code__Pre-sc-k1a3m7-2 bYFTXA prism-code language-terminal is-terminal" style="color:#393A34;background-color:#f6f8fa"><div class="code__AbsoluteCopyButton-sc-k1a3m7-1 zFDDZ copy-button"><div class="copy__CopyComponent-sc-1hcrz7p-0 iRxhpH"><svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg"><rect x="0.5" width="24" height="24" rx="4" fill="#EDF2F7"></rect><path d="M15.5001 6.40002H17.0002C17.398 6.40002 17.7795 6.54752 18.0608 6.81007C18.3422 7.07263 18.5002 7.42872 18.5002 7.80002V17.6C18.5002 17.9713 18.3422 18.3274 18.0608 18.59C17.7795 18.8525 17.398 19 17.0002 19H8.00002C7.60219 19 7.22066 18.8525 6.93935 18.59C6.65804 18.3274 6.5 17.9713 6.5 17.6V7.80002C6.5 7.42872 6.65804 7.07263 6.93935 6.81007C7.22066 6.54752 7.60219 6.40002 8.00002 6.40002H9.50005" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M14.75 5H10.25C9.83579 5 9.5 5.33579 9.5 5.75V7.25C9.5 7.66421 9.83579 8 10.25 8H14.75C15.1642 8 15.5 7.66421 15.5 7.25V5.75C15.5 5.33579 15.1642 5 14.75 5Z" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></div></div><code><div class="code__Line-sc-k1a3m7-3 feDspX token-line" style="background-color:;symb-color:"><span class="code__LineNo-sc-k1a3m7-4 fOOnPz line-no">$</span><span class="code__LineContent-sc-k1a3m7-5 dcafUs  break-words"><span class="token plain">npx prisma migrate resolve --rolled-back add_profile</span></span></div></code></pre></div></div></pre></li></ol></section></section><div class="pageBottom__PageBottomWrapper-sc-10oj3zv-0 fYiqeC"><div class="pageBottom__Feedback-sc-10oj3zv-1 hxlpDS"><h4>Was this helpful?</h4><div class="sentiments"><button id="happy" class=""><svg width="41" height="40" viewBox="0 0 41 40" fill="none" xmlns="http://www.w3.org/2000/svg"><circle cx="20.5" cy="20" r="19.5" stroke="#CBD5E0"><title>This page was helpful.</title></circle><path d="M17.5 17L20.5999 9C21.316 9 22.0028 9.28446 22.5091 9.79081C22.9081 10.1898 23.5 10.9839 23.5 11.7V15H28.3939C28.6548 14.997 28.9133 15.0509 29.1513 15.1577C29.3894 15.2645 29.6013 15.4219 29.7726 15.6188C29.9438 15.8157 30.0701 16.0474 30.1429 16.298C30.2156 16.5486 30.233 16.812 30.1939 17.07L29.9326 19.0738M17.5 17V26.9999M17.5 17H14.3C13.8226 17 13.3648 17.1896 13.0272 17.5272C12.6896 17.8648 12.5 18.3226 12.5 18.8V25.1999C12.5 25.6773 12.6896 26.1351 13.0272 26.4727C13.3648 26.8102 13.8226 26.9999 14.3 26.9999H17.5M17.5 26.9999H27.1519C27.586 27.0048 28.0072 26.8527 28.338 26.5715C28.6688 26.2903 28.8868 25.8991 28.9519 25.4699L29.3306 23M29.9326 19.0738H25.5M29.9326 19.0738L29.3306 23M29.3306 23H25" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></button><button id="unhappy" class=""><svg width="41" height="40" viewBox="0 0 41 40" fill="none" xmlns="http://www.w3.org/2000/svg"><circle cx="20.5" cy="20" r="19.5" stroke="#CBD5E0"><title>This page was not helpful.</title></circle><path d="M23.4999 23L20.4 31C19.6839 31 18.9971 30.7155 18.4908 30.2092C18.0918 29.8102 17.4999 29.0161 17.4999 28.3L17.4999 25H12.606C12.3451 25.003 12.0867 24.9491 11.8486 24.8423C11.6105 24.7355 11.3986 24.5781 11.2274 24.3812C11.0561 24.1843 10.9298 23.9526 10.857 23.702C10.7843 23.4514 10.7669 23.188 10.806 22.93L11.0673 20.9262M23.4999 23L23.4999 13.0001M23.4999 23H26.6999C27.1773 23 27.6351 22.8104 27.9727 22.4728C28.3103 22.1352 28.4999 21.6774 28.4999 21.2V14.8001C28.4999 14.3227 28.3103 13.8649 27.9727 13.5273C27.6351 13.1898 27.1773 13.0001 26.6999 13.0001L23.4999 13.0001M23.4999 13.0001L13.848 13.0001C13.4139 12.9952 12.9927 13.1474 12.6619 13.4285C12.3311 13.7097 12.1131 14.1009 12.048 14.5301L11.6693 17M11.0673 20.9262L15.4999 20.9262M11.0673 20.9262L11.6693 17M11.6693 17L15.9999 17" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></button></div></div><div class="pageBottom__Wrapper-sc-10oj3zv-2 bZehEw"><div class="pageBottom__Content-sc-10oj3zv-3 hJDypS"><div class="Toastify"></div></div></div><a href="https://github.com/prisma/docs/tree/main/content/300-guides/050-database/100-developing-with-prisma-migrate/180-generating-down-migrations.mdx" class="edit-git">Edit this page on GitHub</a></div></div></article><div id="toc-holder" class="layout__TOCWrapper-sc-bupt9j-5 hQpkQZ"><nav aria-label="Table of contents"><div class="toc__ChapterTitle-sc-40h8sh-0 hYiyqD">CONTENT</div><ul class="toc__HeadingList-sc-40h8sh-1 ipeKkr"><li class="toc__ListItem-sc-40h8sh-2 itoEgJ"><a href="#about-down-migrations">About down migrations</a></li><li class="toc__ListItem-sc-40h8sh-2 itoEgJ"><a href="#considerations-when-generating-down-migrations">Considerations when generating down migrations</a></li><li class="toc__ListItem-sc-40h8sh-2 itoEgJ"><a href="#how-to-generate-and-run-down-migrations">How to generate and run down migrations</a></li></ul></nav></div></div></div><div class="footer__FooterWrapper-sc-1ha7kr1-0 cdQlvf"><div class="sc-gKclnd hIjvVO"><div class="column one"><img src="https://images2.prisma.io/footer-logo.png" alt="Prisma Logo" style="width:90px;height:24px"/></div><div class="column two"><div class="group"><h3 class="header">Products</h3><a class="link" href="/client">Prisma Client</a><a class="link" href="/migrate">Prisma Migrate</a><a class="link" href="/studio">Prisma Studio</a><a class="link" href="https://app.prisma.io/login">Prisma 1 Cloud</a><a class="link" href="/dataplatform">Prisma Data Platform</a><a class="link" href="https://pris.ly/roadmap">Product Roadmap</a></div><div class="group"><h3 class="header">Resources</h3><a class="link" href="/docs/">Docs</a><a class="link" href="/docs/getting-started/quickstart">Get Started</a><a class="link" href="/docs/reference/api-reference/prisma-client-reference">API Reference</a><a class="link" href="https://github.com/prisma/prisma-examples">Examples</a><a class="link" href="https://www.howtographql.com/">How to GraphQL</a><a class="link" href="/dataguide/">Data Guide</a></div><div class="group"><h3 class="header">Prisma With</h3><a class="link" href="/nextjs">Prisma with Next.js</a><a class="link" href="/typescript">Prisma with TypeScript</a><a class="link" href="/graphql">Prisma with GraphQL</a><a class="link" href="/apollo">Prisma with Apollo</a><a class="link" href="/nestjs">Prisma with NestJS</a><a class="link" href="/express">Prisma with Express</a><a class="link" href="/hapi">Prisma with hapi</a><a class="link" href="/planetscale">Prisma with Planetscale</a><a class="link" href="/mongodb">Prisma with MongoDB</a></div></div><div class="column three"><div class="group"><h3 class="header">Community</h3><a class="link" href="/ambassador">Prisma Ambassador</a><a class="link" href="/community">Meet the Community</a><a class="link" href="https://slack.prisma.io/">Slack</a><a class="link" href="https://github.com/prisma">GitHub</a><a class="link" href="https://github.com/prisma/prisma/discussions">Discussions</a><a class="link" href="/events">Events</a></div><div class="group"><h3 class="header">Company</h3><a class="link" href="/about">About</a><a class="link" href="/showcase">Showcase</a><a class="link jobs" href="/jobs">Jobs <span class="tag">We&#x27;re hiring!</span></a><a class="link" href="/prisma-enterprise">Prisma Enterprise</a><a class="link" href="http://pris.ly/causes">Causes 🇺🇦</a><a class="link" href="/scholarship">Scholarship</a><a class="link" href="/blog/">Blog</a><a class="link" href="https://pris.ly/privacy">Terms &amp; Privacy</a><a class="link" href="/sitemap">HTML Sitemap</a></div></div><div class="column four"><div class="group"><h3 class="header">Newsletter</h3><p class="description">Stay up to date with the latest features and changes to Prisma</p><div class="newsletter__NewsLetterWrapper-sc-1ns87rd-0 bRSijs"><form class="email"><svg width="22" height="18" viewBox="0 0 22 18" fill="none" xmlns="http://www.w3.org/2000/svg" class="email-icon"><path d="M3 1H19C20.1 1 21 1.9 21 3V15C21 16.1 20.1 17 19 17H3C1.9 17 1 16.1 1 15V3C1 1.9 1.9 1 3 1Z" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M21 3L11 10L1 3" stroke="#A0AEC0" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg><label for="email">Email</label><input type="text" name="email" id="email" placeholder="your@email.com" value=""/><button disabled="" type="submit"><svg width="32" height="32" viewBox="0 0 32 32" fill="none" xmlns="http://www.w3.org/2000/svg"><circle cx="16" cy="16" r="16" fill="#E2E8F0"><title>Subscribe to Prisma newsletter</title></circle><path d="M8 15.5H21.5M18 11L23 15.5L18 20" stroke="#718096" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></button></form></div></div><div class="group"><h3 class="header">Find Us</h3><div class="social"><a href="https://twitter.com/prisma"><svg viewBox="0 0 24 20 " fill="none" role="img" xmlns="http://www.w3.org/2000/svg" aria-labelledby="footerIconTwitter"><title id="footerIconTwitter">Find us on Twitter</title><path d="M23 1.01a10.9 10.9 0 01-3.14 1.53 4.48 4.48 0 00-7.86 3v1a10.66 10.66 0 01-9-4.53s-4 9 5 13a11.64 11.64 0 01-7 2c9 5 20 0 20-11.5 0-.278-.028-.556-.08-.83A7.72 7.72 0 0023 1.01v0z" stroke="#2D3748" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></a><a href="https://www.youtube.com/prismadata"><svg viewBox="0 0 25 18" fill="none" role="img" xmlns="http://www.w3.org/2000/svg" aria-labelledby="footerIconYT"><title id="footerIconYT">Find us on YouTube</title><path d="M22.54 3.42a2.78 2.78 0 00-1.94-2C18.88 1 12 1 12 1s-6.88 0-8.6.46a2.78 2.78 0 00-1.94 2A29 29 0 001 8.75a29 29 0 00.46 5.33A2.78 2.78 0 003.4 16c1.72.46 8.6.46 8.6.46s6.88 0 8.6-.46a2.78 2.78 0 001.94-2c.313-1.732.467-3.49.46-5.25a29.005 29.005 0 00-.46-5.33v0z" stroke="#2D3748" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path><path d="M9.75 12.02l5.75-3.27-5.75-3.27v6.54z" stroke="#2D3748" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></a><a href="https://slack.prisma.io/"><svg viewBox="0 0 26 26" fill="none" role="img" xmlns="http://www.w3.org/2000/svg" aria-labelledby="footerIconSlack"><title id="footerIconSlack">Join us on Slack</title><path d="M16 10.6c-.996 0-1.8-.804-1.8-1.8v-6c0-.996.804-1.8 1.8-1.8s1.8.804 1.8 1.8v6c0 .996-.804 1.8-1.8 1.8zM23.2 10.6h-1.8V8.8c0-.996.804-1.8 1.8-1.8s1.8.804 1.8 1.8-.804 1.8-1.8 1.8zM10 15.4c.996 0 1.8.804 1.8 1.8v6c0 .996-.804 1.8-1.8 1.8s-1.8-.804-1.8-1.8v-6c0-.996.804-1.8 1.8-1.8zM2.8 15.4h1.8v1.8c0 .996-.804 1.8-1.8 1.8S1 18.196 1 17.2s.804-1.8 1.8-1.8zM15.4 16c0-.996.804-1.8 1.8-1.8h6c.996 0 1.8.804 1.8 1.8s-.804 1.8-1.8 1.8h-6c-.996 0-1.8-.804-1.8-1.8zM17.2 21.4h-1.8v1.8c0 .996.804 1.8 1.8 1.8s1.8-.804 1.8-1.8-.804-1.8-1.8-1.8zM10.6 10c0-.996-.804-1.8-1.8-1.8h-6C1.804 8.2 1 9.004 1 10s.804 1.8 1.8 1.8h6c.996 0 1.8-.804 1.8-1.8zM8.8 4.6h1.8V2.8c0-.996-.804-1.8-1.8-1.8S7 1.804 7 2.8s.804 1.8 1.8 1.8z" stroke="#2D3748" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></a><a href="https://github.com/prisma"><svg viewBox="0 0 25 26" fill="none" role="img" xmlns="http://www.w3.org/2000/svg" aria-labelledby="footerIconGH"><title id="footerIconGH">Find us on GitHub</title><path d="M8.99 21.576C3.283 23.288 3.283 18.722 1 18.152M16.98 25v-4.417a3.847 3.847 0 00-1.073-2.98c3.584-.399 7.35-1.757 7.35-7.99a6.21 6.21 0 00-1.712-4.28 5.787 5.787 0 00-.103-4.302S20.096.63 16.98 2.72a15.272 15.272 0 00-7.99 0C5.874.63 4.527 1.03 4.527 1.03a5.787 5.787 0 00-.103 4.304 6.21 6.21 0 00-1.712 4.314c0 6.187 3.767 7.545 7.35 7.99a3.847 3.847 0 00-1.072 2.945V25" stroke="#2D3748" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"></path></svg></a></div><p class="copyright">Prisma © 2018-<!-- -->2022<!-- -->.</p><p class="berlin">Made with ❤️ in Berlin and worldwide</p></div></div></div></div></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/guides/database/developing-with-prisma-migrate/generating-down-migrations";/*]]>*/</script><script id="gatsby-chunk-mapping">/*<![CDATA[*/window.___chunkMapping={"polyfill":["/polyfill-4c8cf0da8d530a0dbc97.js"],"app":["/app-cffd32f265adc6b77259.js"],"component---src-layouts-article-layout-tsx":["/component---src-layouts-article-layout-tsx-2d80d8c29bf510b8b3ed.js"],"component---src-pages-404-tsx":["/component---src-pages-404-tsx-e03d251f7051f56509e6.js"],"component---src-pages-index-tsx":["/component---src-pages-index-tsx-a90d8e07b2b218ed5589.js"]};/*]]>*/</script><script src="/docs/polyfill-4c8cf0da8d530a0dbc97.js" nomodule=""></script><script src="/docs/component---src-layouts-article-layout-tsx-2d80d8c29bf510b8b3ed.js" async=""></script><script src="/docs/0e04aa12d481739ffad563c50dc3aa0ca8c758e7-8e45cf0613a383a32ee2.js" async=""></script><script src="/docs/commons-3a1dee571d9f75b161e1.js" async=""></script><script src="/docs/2645202e-1bd79d58a81929c547b4.js" async=""></script><script src="/docs/styles-7d4153d260c0197f0043.js" async=""></script><script src="/docs/app-cffd32f265adc6b77259.js" async=""></script><script src="/docs/framework-5c89213cc2eecdd79e32.js" async=""></script><script src="/docs/webpack-runtime-a79a71545ca7ea037d9c.js" async=""></script></body></html>